aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2018-09-23 16:18:33 +0300
committerJimi Huotari <chiitoo@gentoo.org>2018-09-23 17:57:38 +0300
commit182b079cd39004a600b9dddce6d47449574fd5fc (patch)
tree1aa34804485a78180ae20a9f85e9774522e8582c /lxqt-base/lxqt-powermanagement
parentlxqt-base/lxqt-themes: move to x11-themes/lxqt-themes (diff)
downloadqt-182b079cd39004a600b9dddce6d47449574fd5fc.tar.gz
qt-182b079cd39004a600b9dddce6d47449574fd5fc.tar.bz2
qt-182b079cd39004a600b9dddce6d47449574fd5fc.zip
lxqt: sync related ebuilds/metadata with the main Gentoo repo tree
With this, the metadata and 9999 ebuilds are in sync with the 0.13.0 versions found via the official Gentoo repository tree, with the following exceptions: - Polkit is optional. - Some of the USE-flags are not used/included in the metadata. - A patch for 'lxqt-config' is not needed. - The handling of translations has been changed upstream, so 'lxqt-meta' does not depend on 'lxqt-l10n' due to file collisions. Package-Manager: Portage-2.3.49, Repoman-2.3.11
Diffstat (limited to 'lxqt-base/lxqt-powermanagement')
-rw-r--r--lxqt-base/lxqt-powermanagement/lxqt-powermanagement-9999.ebuild35
-rw-r--r--lxqt-base/lxqt-powermanagement/metadata.xml11
2 files changed, 27 insertions, 19 deletions
diff --git a/lxqt-base/lxqt-powermanagement/lxqt-powermanagement-9999.ebuild b/lxqt-base/lxqt-powermanagement/lxqt-powermanagement-9999.ebuild
index 879b1c8e..e6419f89 100644
--- a/lxqt-base/lxqt-powermanagement/lxqt-powermanagement-9999.ebuild
+++ b/lxqt-base/lxqt-powermanagement/lxqt-powermanagement-9999.ebuild
@@ -1,25 +1,26 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit cmake-utils
+
+inherit cmake-utils eapi7-ver
DESCRIPTION="LXQt daemon for power management and auto-suspend"
-HOMEPAGE="http://lxqt.org/"
+HOMEPAGE="https://lxqt.org/"
-if [[ ${PV} == *9999* ]]; then
+if [[ ${PV} = *9999* ]]; then
inherit git-r3
- EGIT_REPO_URI="https://github.com/lxde/${PN}.git"
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
else
- SRC_URI="https://github.com/lxde/${PN}/releases/download/${PV}/${P}.tar.xz"
+ SRC_URI="https://downloads.lxqt.org/downloads/${PN}/${PV}/${P}.tar.xz"
KEYWORDS="~amd64 ~arm ~arm64 ~x86"
fi
LICENSE="LGPL-2.1+"
SLOT="0"
-CDEPEND="
- >=dev-libs/libqtxdg-2.0.0
+RDEPEND="
+ >=dev-libs/libqtxdg-3.0.0
dev-qt/qtcore:5
dev-qt/qtdbus:5
dev-qt/qtgui:5
@@ -28,18 +29,22 @@ CDEPEND="
dev-qt/qtx11extras:5
kde-frameworks/kidletime:5
kde-frameworks/solid:5
- lxqt-base/liblxqt
+ =lxqt-base/liblxqt-$(ver_cut 1-2)*
+ || (
+ sys-power/upower
+ sys-power/upower-pm-utils
+ )
+ !lxqt-base/lxqt-common
"
-DEPEND="${CDEPEND}
+DEPEND="${RDEPEND}
dev-qt/linguist-tools:5
- >=dev-util/lxqt-build-tools-0.3.1
+ >=dev-util/lxqt-build-tools-0.5.0
virtual/pkgconfig
"
-RDEPEND="${CDEPEND}
- || ( sys-power/upower sys-power/upower-pm-utils )
-"
src_configure() {
- local mycmakeargs=( -DPULL_TRANSLATIONS=OFF )
+ local mycmakeargs=(
+ -DPULL_TRANSLATIONS=OFF
+ )
cmake-utils_src_configure
}
diff --git a/lxqt-base/lxqt-powermanagement/metadata.xml b/lxqt-base/lxqt-powermanagement/metadata.xml
index a40a83a9..d2a33a0e 100644
--- a/lxqt-base/lxqt-powermanagement/metadata.xml
+++ b/lxqt-base/lxqt-powermanagement/metadata.xml
@@ -1,8 +1,11 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<maintainer type="project">
- <email>lxqt@gentoo.org</email>
- <name>LXQt</name>
- </maintainer>
+ <maintainer type="project">
+ <email>lxqt@gentoo.org</email>
+ <name>LXQt</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">lxqt/lxqt-powermanagement</remote-id>
+ </upstream>
</pkgmetadata>