aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/qps/qps-9999.ebuild')
-rw-r--r--x11-misc/qps/qps-9999.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/x11-misc/qps/qps-9999.ebuild b/x11-misc/qps/qps-9999.ebuild
new file mode 100644
index 00000000..43aa91df
--- /dev/null
+++ b/x11-misc/qps/qps-9999.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake xdg-utils
+
+DESCRIPTION="Qt GUI Process Manager"
+HOMEPAGE="https://lxqt-project.org/"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-2 GPL-2+ LGPL-2.1+ QPL-1.0"
+SLOT="0"
+
+BDEPEND="
+ >=dev-qt/qttools-6.6:6[linguist]
+ >=dev-util/lxqt-build-tools-2.0.0
+"
+DEPEND="
+ >=dev-qt/qtbase-6.6:6[gui,widgets]
+ >=lxqt-base/liblxqt-2.0:=
+"
+RDEPEND="${DEPEND}"
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}