summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArtem Sidorenko (Scader) <artem@2realities.com>2012-01-29 20:50:57 +0000
committerArtem Sidorenko (Scader) <artem@2realities.com>2012-01-29 20:50:57 +0000
commitaa5a03c5e1dee3763955cafca60900b805b87ecd (patch)
tree7aaccb7e3eac74e15764936357e9441f51556a70 /sys-auth
parentwww-apache/mod_authn_otp: New ebuild for bug 401273 (diff)
downloadsunrise-reviewed-aa5a03c5e1dee3763955cafca60900b805b87ecd.tar.gz
sunrise-reviewed-aa5a03c5e1dee3763955cafca60900b805b87ecd.tar.bz2
sunrise-reviewed-aa5a03c5e1dee3763955cafca60900b805b87ecd.zip
sys-auth/oath-toolkit: New Ebuild for bug 401409
svn path=/sunrise/; revision=12715
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/oath-toolkit/ChangeLog10
-rw-r--r--sys-auth/oath-toolkit/Manifest4
-rw-r--r--sys-auth/oath-toolkit/metadata.xml5
-rw-r--r--sys-auth/oath-toolkit/oath-toolkit-1.10.5.ebuild30
4 files changed, 49 insertions, 0 deletions
diff --git a/sys-auth/oath-toolkit/ChangeLog b/sys-auth/oath-toolkit/ChangeLog
new file mode 100644
index 000000000..e7324280b
--- /dev/null
+++ b/sys-auth/oath-toolkit/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sys-auth/oath-toolkit
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*oath-toolkit-1.10.5 (29 Jan 2012)
+
+ 29 Jan 2012; Artem Sidorenko (Scader) <artem@2realities.com>
+ +oath-toolkit-1.10.5.ebuild, +metadata.xml:
+ New Ebuild for bug 401409
+
diff --git a/sys-auth/oath-toolkit/Manifest b/sys-auth/oath-toolkit/Manifest
new file mode 100644
index 000000000..e1a30d4cb
--- /dev/null
+++ b/sys-auth/oath-toolkit/Manifest
@@ -0,0 +1,4 @@
+DIST oath-toolkit-1.10.5.tar.gz 1876773 RMD160 52c09b838b10df8536e3f122e1b829eec1f830f4 SHA1 b3fddfbc442c7cffe854ec159466155ef6ce0cbc SHA256 7a710756f5593965954aa6cffdd0aa7bded7b48f4cb807821b927d8c70bf689c
+EBUILD oath-toolkit-1.10.5.ebuild 635 RMD160 c1df816a4374048cef91aea0415cadc52b970f8e SHA1 a5fda692daea304383b0962922a2bb559fd8793f SHA256 02dde68b8d2e7bea233b859384199c3745ba181e91a201cab39c55b9b388cd63
+MISC ChangeLog 296 RMD160 9362e57a46364bf057bec3393f8ff917f465e837 SHA1 7002a5c3bb6404f9376abec20dcdde32e4cc9856 SHA256 1ab6fd2f9252476e36b8aac38ffa93b8b3937aaa3709c66c19568d6036218ccc
+MISC metadata.xml 200 RMD160 2b20a5237211e577262ebf219e34d06b2730696e SHA1 b3bd01b0092be80c3d1629a13aa3b64adb7a701b SHA256 d25604d7a348fbc2d7592b6b439fdd9b470416a8ab201fee69a445ebe1a9985e
diff --git a/sys-auth/oath-toolkit/metadata.xml b/sys-auth/oath-toolkit/metadata.xml
new file mode 100644
index 000000000..57a348d5c
--- /dev/null
+++ b/sys-auth/oath-toolkit/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer><email>artem@2realities.com</email></maintainer>
+</pkgmetadata>
diff --git a/sys-auth/oath-toolkit/oath-toolkit-1.10.5.ebuild b/sys-auth/oath-toolkit/oath-toolkit-1.10.5.ebuild
new file mode 100644
index 000000000..e00817754
--- /dev/null
+++ b/sys-auth/oath-toolkit/oath-toolkit-1.10.5.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+inherit pam
+
+DESCRIPTION="Toolkit for using one-time password authentication with HOTP/TOTP algorithms"
+HOMEPAGE="http://www.nongnu.org/oath-toolkit/"
+SRC_URI="http://download.savannah.gnu.org/releases/${PN}/${P}.tar.gz"
+LICENSE="GPL-3 LGPL-2.1"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="pam"
+
+DEPEND="pam? ( virtual/pam )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ econf $(use_enable pam) --with-pam-dir=$(getpam_mod_dir)
+}
+
+src_install() {
+ default
+ if use pam; then
+ newdoc pam_oath/README README.pam
+ fi
+}