summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/qtemu/files/1.0.5-help_and_translation_paths.patch')
-rw-r--r--app-emulation/qtemu/files/1.0.5-help_and_translation_paths.patch63
1 files changed, 0 insertions, 63 deletions
diff --git a/app-emulation/qtemu/files/1.0.5-help_and_translation_paths.patch b/app-emulation/qtemu/files/1.0.5-help_and_translation_paths.patch
deleted file mode 100644
index 8fc1680aa..000000000
--- a/app-emulation/qtemu/files/1.0.5-help_and_translation_paths.patch
+++ /dev/null
@@ -1,63 +0,0 @@
-diff -Naur qtemu-1.0.5.orig/CMakeLists.txt qtemu-1.0.5/CMakeLists.txt
---- qtemu-1.0.5.orig/CMakeLists.txt 2008-02-22 19:32:43.000000000 +0100
-+++ qtemu-1.0.5/CMakeLists.txt 2008-02-22 19:35:29.000000000 +0100
-@@ -114,7 +114,7 @@
- DEPENDS ${QM_FILES})
-
- INSTALL (FILES ${QM_FILES}
-- DESTINATION translations)
-+ DESTINATION share/qtemu/translations)
- # translation end
-
- SET(QT_USE_QTXML)
-@@ -146,13 +146,13 @@
- )
-
- FILE(GLOB helpfiles "${CMAKE_CURRENT_SOURCE_DIR}/help/*.png")
--INSTALL(FILES ${helpfiles} DESTINATION help)
-+INSTALL(FILES ${helpfiles} DESTINATION share/qtemu/help)
-
--INSTALL(FILES ${CMAKE_CURRENT_SOURCE_DIR}/help/main.htm DESTINATION help)
-+INSTALL(FILES ${CMAKE_CURRENT_SOURCE_DIR}/help/main.htm DESTINATION share/qtemu/help)
-
- FILE(GLOB helpfiles_de "${CMAKE_CURRENT_SOURCE_DIR}/help/de/*.png")
--INSTALL(FILES ${helpfiles_de} DESTINATION help/de)
-+INSTALL(FILES ${helpfiles_de} DESTINATION share/qtemu/help/de)
-
--INSTALL(FILES ${CMAKE_CURRENT_SOURCE_DIR}/help/de/main.htm DESTINATION help/de)
-+INSTALL(FILES ${CMAKE_CURRENT_SOURCE_DIR}/help/de/main.htm DESTINATION share/qtemu/help/de)
-
- INSTALL(TARGETS qtemu DESTINATION bin)
-diff -Naur qtemu-1.0.5.orig/helpwindow.cpp qtemu-1.0.5/helpwindow.cpp
---- qtemu-1.0.5.orig/helpwindow.cpp 2008-02-22 19:32:44.000000000 +0100
-+++ qtemu-1.0.5/helpwindow.cpp 2008-02-22 19:33:26.000000000 +0100
-@@ -80,7 +80,7 @@
- return testUrl;
-
- //check for case when qtemu executable is in bin/ (installed on linux)
-- testUrl = QUrl(QCoreApplication::applicationDirPath()+"/../help/" + locale + "/main.htm");
-+ testUrl = QUrl(QCoreApplication::applicationDirPath()+"/../share/qtemu/help/" + locale + "/main.htm");
- if (QFile::exists(testUrl.toString()))
- return testUrl;
- }
-@@ -96,7 +96,7 @@
- return testUrl;
-
- //check for case when qtemu executable is in bin/ (installed on linux)
-- testUrl = QUrl(QCoreApplication::applicationDirPath()+"/../help/main.htm");
-+ testUrl = QUrl(QCoreApplication::applicationDirPath()+"/../share/qtemu/help/main.htm");
- if (QFile::exists(testUrl.toString()))
- return testUrl;
-
-diff -Naur qtemu-1.0.5.orig/main.cpp qtemu-1.0.5/main.cpp
---- qtemu-1.0.5.orig/main.cpp 2008-02-22 19:32:43.000000000 +0100
-+++ qtemu-1.0.5/main.cpp 2008-02-22 19:36:32.000000000 +0100
-@@ -45,7 +45,7 @@
- translator.load(path);
- else
- {
-- path = QCoreApplication::applicationDirPath()+"/../translations/qtemu_" + locale + ".qm";
-+ path = QCoreApplication::applicationDirPath()+"/../share/qtemu/translations/qtemu_" + locale + ".qm";
- if (QFile::exists(path))
- translator.load(path);
- }