summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2010-05-26 16:59:30 +0200
committerChristoph Mende <angelos@gentoo.org>2010-05-26 16:59:30 +0200
commit012c061b8488702136c4ad7a5f5f59906e7cca7e (patch)
tree7641eac20f1543bf09ab1533b397dff2265fc7d8
parentlibxfce4util: Removed 4.7.0 (diff)
downloadxfce-012c061b8488702136c4ad7a5f5f59906e7cca7e.tar.gz
xfce-012c061b8488702136c4ad7a5f5f59906e7cca7e.tar.bz2
xfce-012c061b8488702136c4ad7a5f5f59906e7cca7e.zip
thunar: Updated
-rw-r--r--xfce-base/thunar/Manifest2
-rw-r--r--xfce-base/thunar/thunar-9999.ebuild81
2 files changed, 39 insertions, 44 deletions
diff --git a/xfce-base/thunar/Manifest b/xfce-base/thunar/Manifest
index 1a3aa6c..845042e 100644
--- a/xfce-base/thunar/Manifest
+++ b/xfce-base/thunar/Manifest
@@ -1,2 +1,2 @@
-EBUILD thunar-9999.ebuild 1775 RMD160 7b6fded285113a5b68aa18c813ea6240931639fd SHA1 b5f3edf4cdfabfae4deafaec2bdf9ba22313e605 SHA256 4150e315e11b26b7f1182feb54f21b18d7035c6e452916f90903614f82532526
+EBUILD thunar-9999.ebuild 1616 RMD160 69749c77bc2987cf7174a523f7a687c459ebd6f1 SHA1 9eead733c877bd78e99e7dd50fefd4dd21ada973 SHA256 d2ecc64ca4cec31f83b177cb6abd6709fad6511aa26924ec07921260b3cd28e8
MISC metadata.xml 234 RMD160 5cf371faf236f472c7d98a92d7103c5a96c4d95a SHA1 f028da2a6c812a70d5a6c159a450899a5c8f29a2 SHA256 acb3aa4d6a184bbefb0ae06cbb0ed0416ecd1b87d01cae543365cfc0e330d8cb
diff --git a/xfce-base/thunar/thunar-9999.ebuild b/xfce-base/thunar/thunar-9999.ebuild
index 736608e..097d1d2 100644
--- a/xfce-base/thunar/thunar-9999.ebuild
+++ b/xfce-base/thunar/thunar-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
@@ -8,64 +8,59 @@ inherit virtualx xfce4
xfce4_core
-DESCRIPTION="File manager"
-HOMEPAGE="http://thunar.xfce.org"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE="dbus debug doc exif gnome hal pcre startup-notification +trash-plugin"
-SLOT="0"
+DESCRIPTION="File manager for Xfce4"
+HOMEPAGE="http://thunar.xfce.org/"
-RDEPEND=">=dev-lang/perl-5.6
- >=dev-libs/glib-2.6:2
- >=dev-util/desktop-file-utils-0.14
- >=media-libs/freetype-2
- >=media-libs/jpeg-6b
- >=media-libs/libpng-1.2.0
- virtual/fam
- >=x11-libs/gtk+-2.6:2
- x11-libs/libSM
- >=x11-misc/shared-mime-info-0.20
- >=xfce-base/exo-0.3.92[hal?]
- >=xfce-base/libxfce4util-${XFCE_VERSION}
+LICENSE="GPL-2 LGPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="dbus debug exif pcre startup-notification test +trash-plugin"
+
+COMMON_DEPEND=">=xfce-base/exo-0.5.1
+ >=dev-libs/glib-2.18:2
+ >=x11-libs/gtk+-2.14:2
+ >=xfce-base/libxfce4util-4.6
+ >=xfce-base/libxfce4ui-4.7.1
+ >=dev-lang/perl-5.6
dbus? ( dev-libs/dbus-glib )
- exif? ( >=media-libs/libexif-0.6 )
- hal? ( dev-libs/dbus-glib
- sys-apps/hal )
- gnome? ( gnome-base/gconf )
+ exif? ( >=media-libs/libexif-0.6.19 )
pcre? ( >=dev-libs/libpcre-6 )
startup-notification? ( x11-libs/startup-notification )
trash-plugin? ( dev-libs/dbus-glib
- >=xfce-base/xfce4-panel-${XFCE_VERSION} )"
-DEPEND="${RDEPEND}
+ >=xfce-base/xfce4-panel-4.3.90 )"
+RDEPEND="${COMMON_DEPEND}
+ >=x11-misc/shared-mime-info-0.70
+ >=dev-util/desktop-file-utils-0.15"
+DEPEND="${COMMON_DEPEND}
dev-util/intltool
- dev-util/gtk-doc"
+ dev-util/pkgconfig
+ sys-devel/gettext"
WANT_GTKDOCIZE="yes"
pkg_setup() {
- XFCE_CONFIG+="$(use_enable dbus) $(use_enable doc gtk-doc)
- $(use_enable exif) $(use_enable gnome gnome-thumbnailers)
- $(use_enable pcre)"
-
- if use hal && ! use dbus; then
- ewarn "USE hal detected, enabling dbus."
- fi
+ XFCE_CONFIG+=" $(use_enable dbus)
+ $(use_enable exif)
+ $(use_enable pcre)
+ --with-html-dir=${EPREFIX}/usr/share/doc/${PF}/html"
- if use hal; then
- XFCE_CONFIG+=" --enable-dbus --with-volume-manager=hal"
- else
- XFCE_CONFIG+=" --with-volume-manager=none"
- fi
-
- if use trash-plugin && ! use dbus; then
+ if use trash-plugin; then
XFCE_CONFIG+=" --enable-dbus"
- ewarn "USE trash-plugin detected, enabling dbus."
+ else
+ XFCE_CONFIG+=" --disable-tpa-plugin"
fi
- use trash-plugin || XFCE_CONFIG+=" --disable-tpa-plugin"
+ DOCS="AUTHORS ChangeLog FAQ HACKING NEWS README THANKS TODO"
}
src_test() {
- Xemake check || die "emake check failed"
+ Xemake check || die
}
-DOCS="AUTHORS ChangeLog FAQ HACKING NEWS README THANKS TODO"
+pkg_postinst() {
+ xfce4_pkg_postinst
+
+ echo
+ elog "If you are seeing some odd dbus error, make sure your user is in the"
+ elog "plugdev group. See Gentoo bug #279077 for more info"
+ echo
+}