summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2008-11-10 21:36:21 +0100
committerChristoph Mende <angelos@gentoo.org>2008-11-10 21:36:21 +0100
commit128a7d750bcd30a3ae22520701d0e442095af86d (patch)
treef751bb39dce1f9d2576741fcfb09719346519382 /eclass
parentxfmpc: Added ~sparc ~x86 (diff)
downloadxfce-128a7d750bcd30a3ae22520701d0e442095af86d.tar.gz
xfce-128a7d750bcd30a3ae22520701d0e442095af86d.tar.bz2
xfce-128a7d750bcd30a3ae22520701d0e442095af86d.zip
Move autogen.sh fixing to src_unpack and adjust it so it actually works with current trunk
Diffstat (limited to 'eclass')
-rw-r--r--eclass/xfce4.eclass23
1 files changed, 16 insertions, 7 deletions
diff --git a/eclass/xfce4.eclass b/eclass/xfce4.eclass
index c607332..cbef2a2 100644
--- a/eclass/xfce4.eclass
+++ b/eclass/xfce4.eclass
@@ -101,6 +101,21 @@ xfce4_single_make() {
JOBS="-j1"
}
+# @FUNCTION: xfce4_src_unpack
+# @DESCRIPTION:
+# Only used for live ebuilds. Patch autogen.sh to inject the correct revision
+# into configure.ac
+xfce4_src_unpack() {
+ if [[ ${PV} = 9999* ]]; then
+ subversion_src_unpack
+ einfo "Patching autogen.sh"
+ sed -i \
+ -e "s:\.svn:${ESVN_STORE_DIR}/${ESVN_PROJECT}/${ESVN_REPO_URI##*/}/.svn:" \
+ -e "s:svn info \$0:svn info ${ESVN_STORE_DIR}/${ESVN_PROJECT}/${ESVN_REPO_URI##*/}:" autogen.sh \
+ || die "sed failed"
+ fi
+}
+
# @FUNCTION: xfce4_src_compile
# @DESCRIPTION:
# Package compilation
@@ -108,12 +123,6 @@ xfce4_single_make() {
# startup-notification and debug are automatically added when they are found in
# IUSE, gtk-doc is added when doc is found in IUSE
xfce4_src_compile() {
- if [[ ${PV} = 9999* ]]; then
- einfo "Patching autogen.sh"
- sed -i -e "s:svn info \$0:svn info ${ESVN_STORE_DIR}/${ESVN_PROJECT}/${ESVN_REPO_URI##*/}:" autogen.sh \
- || die "sed failed"
- fi
-
if has doc ${IUSE}; then
XFCE_CONFIG+=" $(use_enable doc gtk-doc)"
fi
@@ -179,4 +188,4 @@ xfce4_pkg_postrm() {
gnome2_icon_cache_update
}
-EXPORT_FUNCTIONS src_compile src_install pkg_preinst pkg_postinst pkg_postrm
+EXPORT_FUNCTIONS src_unpack src_compile src_install pkg_preinst pkg_postinst pkg_postrm