summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Dibb <beandog@gentoo.org>2010-01-02 19:20:57 +0000
committerSteve Dibb <beandog@gentoo.org>2010-01-02 19:20:57 +0000
commit93f26bcaa8027d961efca09d242ca25f40c947cf (patch)
tree5138ba06ad51a0bc60372aec64afb17fcf1d57f1 /class.portage.ebuild.php
parentgit-svn-id: file:///var/svn/portage@37 3218660a-b0cf-4799-a991-8ddcc5b9e0f3 (diff)
downloadznurt-org-backend-93f26bcaa8027d961efca09d242ca25f40c947cf.tar.gz
znurt-org-backend-93f26bcaa8027d961efca09d242ca25f40c947cf.tar.bz2
znurt-org-backend-93f26bcaa8027d961efca09d242ca25f40c947cf.zip
pull source as well
git-svn-id: file:///var/svn/portage@38 3218660a-b0cf-4799-a991-8ddcc5b9e0f3
Diffstat (limited to 'class.portage.ebuild.php')
-rw-r--r--class.portage.ebuild.php5
1 files changed, 5 insertions, 0 deletions
diff --git a/class.portage.ebuild.php b/class.portage.ebuild.php
index 97cea90..73391f6 100644
--- a/class.portage.ebuild.php
+++ b/class.portage.ebuild.php
@@ -44,6 +44,7 @@
// File properties
private $filename;
+ private $source;
private $category;
@@ -157,6 +158,10 @@
case 'filename':
return $this->filename;
break;
+
+ case 'source':
+ return $this->source = file_get_contents($this->filename);
+ break;
}