summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>2020-01-02 02:45:46 +0000
committerJorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>2020-01-02 02:45:46 +0000
commite5cf8365e95ff77214cd8a6845715e3307ac141b (patch)
tree68e28deb02a216fd575d2343a4e99e8b82caaecb
parentdev-db/phpmyadmin: Drop removed keyword from existing ebuilds. (diff)
downloadjmbsvicetto-e5cf8365e95ff77214cd8a6845715e3307ac141b.tar.gz
jmbsvicetto-e5cf8365e95ff77214cd8a6845715e3307ac141b.tar.bz2
jmbsvicetto-e5cf8365e95ff77214cd8a6845715e3307ac141b.zip
dev-db/phpmyadmin: Bump to releases 4.9.3 and 5.0.0.
The new 5.0.0 release requires at least php-7.1 and has a known issue with authentication, so be sure to read https://www.phpmyadmin.net/news/2019/12/26/phpmyadmin-500-released/ Signed-off-by: Jorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>
-rw-r--r--dev-db/phpmyadmin/Manifest2
-rw-r--r--dev-db/phpmyadmin/phpmyadmin-4.9.3.ebuild61
-rw-r--r--dev-db/phpmyadmin/phpmyadmin-5.0.0.ebuild61
3 files changed, 124 insertions, 0 deletions
diff --git a/dev-db/phpmyadmin/Manifest b/dev-db/phpmyadmin/Manifest
index 51613c1..847247a 100644
--- a/dev-db/phpmyadmin/Manifest
+++ b/dev-db/phpmyadmin/Manifest
@@ -1,2 +1,4 @@
DIST phpMyAdmin-4.9.0.1-all-languages.tar.xz 6066680 BLAKE2B fc949684e97bef1be832968a9c0a3a893e0a81d7984953e694f41ff15deb82bffe3116ff7ec3c832bf2cfd4e24cefec4ce703baa9404bc0740b7231480165a4f SHA512 92fc032ba44e84f6c6a62bb658c2c7ea984bfd8c963b18bf19c26c3991cfe635771376ad8aebf90140bb1bd723b62a5adaca35d88f7bb68169fd0d07c3995356
+DIST phpMyAdmin-4.9.3-all-languages.tar.xz 6136280 BLAKE2B 638fef4a3b50a9c3d528c21d29a2c6d96fe2d425e0cbba03f55fce2bbbda8992cc5723be19ba40bd31ed2adf37fdbc3f382a22c9634bed37f3ac6107e40d06cc SHA512 ac6ec72efde6aad6b20d651328ad0d9440f11b150c38f4043f0e3916b97a15908f60b13a5948ec8767d62499a9d31d0bbe4d764f97f7236de3d7ba9cfc422379
+DIST phpMyAdmin-5.0.0-all-languages.tar.xz 8130456 BLAKE2B f8006ed4b78674d835c348104bd0d6a84ee26ab918080a38cda218399b74d62c8b7fa23d75c87d1705090fe751e39d47f1c66edf2bac03f68a52e5ed40209042 SHA512 7b29193a7376044d05a97f7cf3080c90db23433ba4de98e95dc1162ab740c4facd9a7b52816a9e65b23a72d908746d27ca4df008e752af7117fa89ff7af962c9
DIST phpMyAdmin-5.0.0-alpha1-all-languages.tar.xz 8200540 BLAKE2B 3baffd8942849cb7f6273e46a538d35f1fe7c3bad9b9f7c6dd197f47cd9273469f6b125838caaa0692b479f41f6f1ace48b51b37b0301a131cc91a9b4c7d9108 SHA512 3159e8324997e9584a54aabeb8d9f61b794f64385e915073fe20062f315672536fd482d01056fdcd55ea240bb0b0997b28ec0f023ceb8ae7f2a9affebf666a29
diff --git a/dev-db/phpmyadmin/phpmyadmin-4.9.3.ebuild b/dev-db/phpmyadmin/phpmyadmin-4.9.3.ebuild
new file mode 100644
index 0000000..65c0132
--- /dev/null
+++ b/dev-db/phpmyadmin/phpmyadmin-4.9.3.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit eutils webapp
+
+MY_PV=${PV/_/-}
+MY_PN="phpMyAdmin"
+MY_P="${MY_PN}-${MY_PV}-all-languages"
+
+DESCRIPTION="Web-based administration for MySQL database in PHP"
+HOMEPAGE="https://www.phpmyadmin.net/"
+SRC_URI="https://files.phpmyadmin.net/${MY_PN}/${MY_PV}/${MY_P}.tar.xz"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="setup"
+
+RDEPEND="
+ dev-lang/php[ctype,filter,json,session,unicode]
+ || (
+ dev-lang/php[mysqli]
+ dev-lang/php[mysql]
+ )
+ virtual/httpd-php:*
+"
+
+need_httpd_cgi
+
+S="${WORKDIR}"/${MY_P}
+
+pkg_setup() {
+ webapp_pkg_setup
+}
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc README RELEASE-DATE-${MY_PV} ChangeLog
+ rm -f LICENSE README* RELEASE-DATE-${MY_PV}
+
+ if ! use setup; then
+ rm -rf setup || die "Cannot remove setup utility"
+ elog "The phpMyAdmin setup utility has been removed."
+ elog "It is a regular target of various exploits. If you need it, set USE=setup."
+ else
+ elog "You should consider disabling the setup USE flag"
+ elog "to exclude the setup utility if you don't use it."
+ elog "It regularly is the target of various exploits."
+ fi
+
+ insinto "${MY_HTDOCSDIR#${EPREFIX}}"
+ doins -r .
+
+ webapp_configfile "${MY_HTDOCSDIR#${EPREFIX}}"/libraries/config.default.php
+ webapp_serverowned "${MY_HTDOCSDIR#${EPREFIX}}"/libraries/config.default.php
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en-3.1.txt
+ webapp_src_install
+}
diff --git a/dev-db/phpmyadmin/phpmyadmin-5.0.0.ebuild b/dev-db/phpmyadmin/phpmyadmin-5.0.0.ebuild
new file mode 100644
index 0000000..d526b8b
--- /dev/null
+++ b/dev-db/phpmyadmin/phpmyadmin-5.0.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit eutils webapp
+
+MY_PV=${PV/_/-}
+MY_PN="phpMyAdmin"
+MY_P="${MY_PN}-${MY_PV}-all-languages"
+
+DESCRIPTION="Web-based administration for MySQL database in PHP"
+HOMEPAGE="https://www.phpmyadmin.net/"
+SRC_URI="https://files.phpmyadmin.net/${MY_PN}/${MY_PV}/${MY_P}.tar.xz"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="setup"
+
+RDEPEND="
+ >=dev-lang/php-7.1[ctype,filter,json,session,unicode]
+ || (
+ dev-lang/php[mysqli]
+ dev-lang/php[mysql]
+ )
+ virtual/httpd-php:*
+"
+
+need_httpd_cgi
+
+S="${WORKDIR}"/${MY_P}
+
+pkg_setup() {
+ webapp_pkg_setup
+}
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc README RELEASE-DATE-${MY_PV} ChangeLog
+ rm -f LICENSE README* RELEASE-DATE-${MY_PV}
+
+ if ! use setup; then
+ rm -rf setup || die "Cannot remove setup utility"
+ elog "The phpMyAdmin setup utility has been removed."
+ elog "It is a regular target of various exploits. If you need it, set USE=setup."
+ else
+ elog "You should consider disabling the setup USE flag"
+ elog "to exclude the setup utility if you don't use it."
+ elog "It regularly is the target of various exploits."
+ fi
+
+ insinto "${MY_HTDOCSDIR#${EPREFIX}}"
+ doins -r .
+
+ webapp_configfile "${MY_HTDOCSDIR#${EPREFIX}}"/libraries/config.default.php
+ webapp_serverowned "${MY_HTDOCSDIR#${EPREFIX}}"/libraries/config.default.php
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en-3.1.txt
+ webapp_src_install
+}