summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Tsoy <alexander@tsoy.me>2024-01-02 03:17:49 +0300
committerMiroslav Šulc <fordfrog@gentoo.org>2024-01-03 09:43:37 +0100
commit4590f31ae7dabc26a98483768c051ea216f4466e (patch)
treeeb70834a02427cdb202bca8c3a81ee89f0e6766d
parentnet-print/cups-meta: Keyword 1 riscv, #920237 (diff)
downloadgentoo-4590f31ae7dabc26a98483768c051ea216f4466e.tar.gz
gentoo-4590f31ae7dabc26a98483768c051ea216f4466e.tar.bz2
gentoo-4590f31ae7dabc26a98483768c051ea216f4466e.zip
media-sound/guitarix: fix LTO build
Pass --cxxflags to waf configure. This allows waf to do some magic and append -ffat-lto-objects to CXXFLAGS. Also unexport CXXFLAGS and LDFLAGS before waf configure to prevent duplicating flags. Closes: https://bugs.gentoo.org/860861 Signed-off-by: Alexander Tsoy <alexander@tsoy.me> Closes: https://github.com/gentoo/gentoo/pull/34597 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
-rw-r--r--media-sound/guitarix/guitarix-0.44.1.ebuild5
-rw-r--r--media-sound/guitarix/guitarix-9999.ebuild5
2 files changed, 8 insertions, 2 deletions
diff --git a/media-sound/guitarix/guitarix-0.44.1.ebuild b/media-sound/guitarix/guitarix-0.44.1.ebuild
index 14885014cd74..60b76beb379f 100644
--- a/media-sound/guitarix/guitarix-0.44.1.ebuild
+++ b/media-sound/guitarix/guitarix-0.44.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2019-2023 Gentoo Authors
+# Copyright 2019-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -69,7 +69,10 @@ PATCHES=(
)
src_configure() {
+ export -n {CXX,LD}FLAGS
+
local myconf=(
+ --cxxflags="${CXXFLAGS}"
--cxxflags-debug=""
--cxxflags-release="-DNDEBUG"
--ldflags="${LDFLAGS}"
diff --git a/media-sound/guitarix/guitarix-9999.ebuild b/media-sound/guitarix/guitarix-9999.ebuild
index 0f1305ac3816..ed2429d53f6d 100644
--- a/media-sound/guitarix/guitarix-9999.ebuild
+++ b/media-sound/guitarix/guitarix-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2019-2023 Gentoo Authors
+# Copyright 2019-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -66,7 +66,10 @@ BDEPEND="
DOCS=( changelog README )
src_configure() {
+ export -n {CXX,LD}FLAGS
+
local myconf=(
+ --cxxflags="${CXXFLAGS}"
--cxxflags-debug=""
--cxxflags-release="-DNDEBUG"
--ldflags="${LDFLAGS}"