summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-07-15 11:38:22 +0200
committerMichał Górny <mgorny@gentoo.org>2024-07-15 12:51:04 +0200
commit4b51796f5cee66c1196bb6677adcd5284d1aaee0 (patch)
treed0ae82b7437b807ff7516162fbdf9c8d6d232778
parentgames-emulation/mupen64plus-audio-sdl: Bump to 2.6.0 (diff)
downloadgentoo-4b51796f5cee66c1196bb6677adcd5284d1aaee0.tar.gz
gentoo-4b51796f5cee66c1196bb6677adcd5284d1aaee0.tar.bz2
gentoo-4b51796f5cee66c1196bb6677adcd5284d1aaee0.zip
games-emulation/mupen64plus-input-sdl: Bump to 2.6.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--games-emulation/mupen64plus-input-sdl/Manifest1
-rw-r--r--games-emulation/mupen64plus-input-sdl/mupen64plus-input-sdl-2.6.0.ebuild82
2 files changed, 83 insertions, 0 deletions
diff --git a/games-emulation/mupen64plus-input-sdl/Manifest b/games-emulation/mupen64plus-input-sdl/Manifest
index ab46c51db7ab..7cf08063fad3 100644
--- a/games-emulation/mupen64plus-input-sdl/Manifest
+++ b/games-emulation/mupen64plus-input-sdl/Manifest
@@ -1 +1,2 @@
DIST mupen64plus-input-sdl-src-2.5.9.tar.gz 56403 BLAKE2B 56d6c390783aa4a7f25f72a5295eb11f1ca2a69f2ffe4f0232d4a0c329e9c0eba0a2cbf46e66adfdf0462d2ec5337f7c6c4587ae29de346cd4cfe1d240f4d5fd SHA512 b613396ee05e82aaaf15e955f83b5cb4e854df1fdb34d5e1c96cf0fddf0af79aa5af2ceb19cc9cfeaef707c2ecafd25e0814e3d7715a20b740482d0ece273f2f
+DIST mupen64plus-input-sdl-src-2.6.0.tar.gz 61800 BLAKE2B c09ebf5534172e92e7aa8833a9c2cc708406754fa3a133ac55f2c0b1029d6d3a0c801a8f771d00439cc3832c21b4b3053479526b74e86c2769131ef9d36154de SHA512 ad818ad3da3f30fbf30d08bc2a15319b58d65e91d8460b8d13825947a1f688b0d51daaf797992fa9c3683ff8ba9b4314ddccbb577b9d77656107ab7d8716a479
diff --git a/games-emulation/mupen64plus-input-sdl/mupen64plus-input-sdl-2.6.0.ebuild b/games-emulation/mupen64plus-input-sdl/mupen64plus-input-sdl-2.6.0.ebuild
new file mode 100644
index 000000000000..d82694503535
--- /dev/null
+++ b/games-emulation/mupen64plus-input-sdl/mupen64plus-input-sdl-2.6.0.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+MY_P=${PN}-src-${PV}
+DESCRIPTION="A fork of Mupen64 Nintendo 64 emulator, SDL input plugin"
+HOMEPAGE="https://www.mupen64plus.org/"
+SRC_URI="
+ https://github.com/mupen64plus/${PN}/releases/download/${PV}/${MY_P}.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ >=games-emulation/mupen64plus-core-${PV}:0=
+ media-libs/libsdl2:0=[joystick]
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+
+ # avoid implicitly appending CPU flags
+ sed -i -e 's:-mmmx::g' -e 's:-msse::g' projects/unix/Makefile || die
+}
+
+src_compile() {
+ MAKEARGS=(
+ # Note: please keep this in sync in all of mupen64plus-* packages
+
+ -C projects/unix
+
+ # this basically means: GNU userspace
+ UNAME=Linux
+
+ # verbose output
+ V=1
+
+ CROSS_COMPILE="${CHOST}-"
+ CC="$(tc-getCC)"
+ CXX="$(tc-getCXX)"
+ PKG_CONFIG="$(tc-getPKG_CONFIG)"
+ # usual CFLAGS, CXXFLAGS and LDFLAGS are respected
+ # so we can leave OPTFLAGS empty
+ OPTFLAGS=
+
+ # paths, some of them are used at compile time
+ PREFIX=/usr
+ LIBDIR=/usr/$(get_libdir)
+
+ # disable unwanted magic
+ LDCONFIG=:
+ INSTALL_STRIP_FLAG=
+
+ # Package-specific stuff
+
+ # CROSS_COMPILE causes it to look for ${CHOST}-sdl2-config...
+ SDL_CFLAGS="$($(tc-getPKG_CONFIG) --cflags sdl2)"
+ SDL_LDLIBS="$($(tc-getPKG_CONFIG) --libs sdl2)"
+ )
+
+ use amd64 && MAKEARGS+=( HOST_CPU=x86_64 )
+ use x86 && MAKEARGS+=( HOST_CPU=i386 )
+
+ emake "${MAKEARGS[@]}" all
+}
+
+src_install() {
+ emake "${MAKEARGS[@]}" DESTDIR="${D}" install
+ dodoc AUTHORS README.md RELEASE
+}