summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2025-02-14 17:16:38 +0100
committerUlrich Müller <ulm@gentoo.org>2025-02-22 08:57:49 +0100
commit76eda435d430141036ad82739d7246953a538f3a (patch)
treead9c77565e3cc70e9e7b0f6db4e511884c397c1d
parentdev-db/mongodb: Fix incorrect REPLACING_VERSIONS usage (diff)
downloadgentoo-76eda435d430141036ad82739d7246953a538f3a.tar.gz
gentoo-76eda435d430141036ad82739d7246953a538f3a.tar.bz2
gentoo-76eda435d430141036ad82739d7246953a538f3a.zip
dev-embedded/esptool: Fix incorrect REPLACING_VERSIONS usage
Signed-off-by: Ulrich Müller <ulm@gentoo.org>
-rw-r--r--dev-embedded/esptool/esptool-4.8.1.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/dev-embedded/esptool/esptool-4.8.1.ebuild b/dev-embedded/esptool/esptool-4.8.1.ebuild
index 8036d355abd6..087a54ac1cff 100644
--- a/dev-embedded/esptool/esptool-4.8.1.ebuild
+++ b/dev-embedded/esptool/esptool-4.8.1.ebuild
@@ -7,7 +7,7 @@ PYTHON_COMPAT=( python3_{10..12} )
DISTUTILS_USE_PEP517=setuptools
DISTUTILS_SINGLE_IMPL=1
-inherit distutils-r1
+inherit distutils-r1 eapi9-ver
DESCRIPTION="Utility to communicate with the ROM bootloader in Espressif ESP8266 and ESP32"
HOMEPAGE="https://github.com/espressif/esptool"
@@ -58,7 +58,7 @@ src_prepare() {
}
pkg_postinst() {
- if ver_test ${REPLACING_VERSIONS} -lt 4; then
+ if ver_replacing -lt 4; then
ewarn "${P} - new 4.x release with breaking changes:"
ewarn " - Public API has been defined by limiting access to internals that have been refactored into multiple source files"
ewarn " - If active security features are detected, the default behavior changes to prevent unintentional bricking"