summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-01-06 10:40:59 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-01-06 10:42:33 +0100
commit796b20613cb96c15a6271173bcd36382e5adca0d (patch)
tree94e4acdd7b5640ba8233ec739d806e99e5a31043
parentmedia-gfx/kiconedit: Remove last-rited pkg (diff)
downloadgentoo-796b20613cb96c15a6271173bcd36382e5adca0d.tar.gz
gentoo-796b20613cb96c15a6271173bcd36382e5adca0d.tar.bz2
gentoo-796b20613cb96c15a6271173bcd36382e5adca0d.zip
media-sound/amsynth: bump to 1.7.0
Package-Manager: Portage-2.3.3, Repoman-2.3.1
-rw-r--r--media-sound/amsynth/Manifest1
-rw-r--r--media-sound/amsynth/amsynth-1.7.0.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/media-sound/amsynth/Manifest b/media-sound/amsynth/Manifest
index b8e55b97020f..4c126c18ee83 100644
--- a/media-sound/amsynth/Manifest
+++ b/media-sound/amsynth/Manifest
@@ -1,3 +1,4 @@
DIST amSynth-1.3.2.tar.gz 635901 SHA256 3ad50c20d690865ea0fdef6745cd04a9f758e9ae654ad874902d3da896e0fa75 SHA512 c5f312fd1fa5335ccd2c1e7a81a7c0f9094faabec633fe654f04650e5604bb6d05f1348f6ce3c305e840692e2012ac9501ca83f5e5018a0218d9c35a99678e80 WHIRLPOOL 3b93486378a140ce7feb0789cc46a74375920ae717d38910e0b75011e4f1c827749f795ce38b7408d72adb4abfab090a104fc23f001977c68576bde05e1fa260
DIST amsynth-1.5.1.tar.gz 1297131 SHA256 38e0764ae02ec38e689204581810adabedd9b4e0d306414c455f51c1dbf0bea4 SHA512 5f1551f9d1398a97738ac6f764f169d8cdd55e94464438adb226d1284fe8845e190fe5dd7a740b33972c1bbe76aa2d60467b7a663ec6717bb9fac75e5aac62d1 WHIRLPOOL 615ae1a55db42a0d6cb628ab84d9167894cb974594c45bf74aae6ad1e74b09f0303844fe54457b805ce4fd50af8ae99d9064531162106ef83c5c8103c24c8a73
DIST amsynth-1.6.4.tar.gz 1380770 SHA256 489f57d506ea3495412bdd759be290930ff5da9d5b6b39ad8c82e19b4fd219ed SHA512 63ecc54ff0b26d61aa11a6cd1f6854c6b1f87b723808293a09f1b86831c574c8f709dd7987571914d285c52d94fa794f858c299927918ffa1ddad743bc180abb WHIRLPOOL f5b92d69543c479def140703df11efc27407f4869d0eea5b28ee1e8914c241184e6eccb726cb2d628b629c00c01c944425ea1d82522744ef7d5cbb5c49952634
+DIST amsynth-1.7.0.tar.gz 1399493 SHA256 176bfc8bc7eee60e6826572c8f9e9ce555c11687b063c5fb904836c44b4616b5 SHA512 4b9a56c7800a484b738985cf52f6956e8829c11b4fb10f72c1e3ede0aeb3fdcb424e72ac43995ea3dc988f9cb838a0f284719d274010dc52a115faa8a3beb8d9 WHIRLPOOL 7d631b697dfed88b5a8a4c28bb0b4158384676b472936b0dc735f484096d2a6b14fb555c0af83f74b3120f9a6baac0c4073bf22f194439beb903261d88d70bfa
diff --git a/media-sound/amsynth/amsynth-1.7.0.ebuild b/media-sound/amsynth/amsynth-1.7.0.ebuild
new file mode 100644
index 000000000000..5df8da105c3b
--- /dev/null
+++ b/media-sound/amsynth/amsynth-1.7.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools flag-o-matic
+
+DESCRIPTION="Virtual analogue synthesizer"
+HOMEPAGE="https://github.com/nixxcode/amsynth/"
+SRC_URI="https://github.com/nixxcode/${PN}/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="alsa dssi jack lash oss sndfile"
+
+RDEPEND="dev-cpp/gtkmm:2.4
+ sndfile? ( >=media-libs/libsndfile-1:= )
+ alsa? (
+ media-libs/alsa-lib:=
+ media-sound/alsa-utils
+ )
+ dssi? (
+ media-libs/dssi:=
+ media-libs/liblo:=
+ >=x11-libs/gtk+-2.20:2
+ )
+ jack? ( media-sound/jack-audio-connection-kit )
+ lash? ( media-sound/lash )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ oss? ( virtual/os-headers )"
+
+S="${WORKDIR}/${PN}-release-${PV}"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ append-cxxflags -std=c++11
+ econf \
+ $(use_with oss) \
+ $(use_with alsa) \
+ $(use_with jack) \
+ $(use_with lash) \
+ $(use_with sndfile) \
+ $(use_with dssi)
+}