summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-22 06:39:32 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-22 06:49:04 +0200
commit82df9ddda36ab0e28a500d8ea79c8251b43291ef (patch)
tree711c2d482464449837b15522c3e028b98b08bba5
parentdev-python/requests-file: Bump to 2.1.0 (diff)
downloadgentoo-82df9ddda36ab0e28a500d8ea79c8251b43291ef.tar.gz
gentoo-82df9ddda36ab0e28a500d8ea79c8251b43291ef.tar.bz2
gentoo-82df9ddda36ab0e28a500d8ea79c8251b43291ef.zip
dev-python/sphinx-notfound-page: Bump to 1.0.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/sphinx-notfound-page/Manifest1
-rw-r--r--dev-python/sphinx-notfound-page/sphinx-notfound-page-1.0.1.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/sphinx-notfound-page/Manifest b/dev-python/sphinx-notfound-page/Manifest
index 9e83ebdcb588..e9ee7ab3a724 100644
--- a/dev-python/sphinx-notfound-page/Manifest
+++ b/dev-python/sphinx-notfound-page/Manifest
@@ -1 +1,2 @@
DIST sphinx-notfound-page-1.0.0.gh.tar.gz 543729 BLAKE2B 87da323277a38b20d43fa23e67528fee9530a243aa557a2be279a4a6877ac18bc36546beba0c6cc4ff598410d4be3a4337c7508005064df52867dca2675c8a3d SHA512 e9d235fb0461ee9f349a57d37caeaf4cb4ec5faab7e731067e69467bf0990d5c5ce31d024fe2ac531fb84f49a4e2e74092ce09d5977135c759669523fc59ab4e
+DIST sphinx-notfound-page-1.0.1.gh.tar.gz 543803 BLAKE2B e1d7c568a0d7bfdde3cde397424d8e5e00291ec442278613bcc9dcf1fdd372ad3483e9e0fd23e9e9dd2bcdbfe4ec33c6ddfbd21705ee73743820b2e46b3f6718 SHA512 464373abf7b9d1025a339eb83305800866f0b8bfc53fbc1d320637c4be9016aa36daf2f22a9ed47224db0f64d5c3236a35b291681a56e9f2f7a2b6aec96a40a2
diff --git a/dev-python/sphinx-notfound-page/sphinx-notfound-page-1.0.1.ebuild b/dev-python/sphinx-notfound-page/sphinx-notfound-page-1.0.1.ebuild
new file mode 100644
index 000000000000..d7552cfa7cd8
--- /dev/null
+++ b/dev-python/sphinx-notfound-page/sphinx-notfound-page-1.0.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2019-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Create a custom 404 page with absolute URLs hardcoded"
+HOMEPAGE="
+ https://sphinx-notfound-page.readthedocs.io/
+ https://github.com/readthedocs/sphinx-notfound-page/
+ https://pypi.org/project/sphinx-notfound-page/
+"
+SRC_URI="
+ https://github.com/readthedocs/sphinx-notfound-page/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ >=dev-python/sphinx-5[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # calls sphinx-build directly, works around venv
+ tests/test_urls.py::test_parallel_build
+)