summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2020-08-20 22:27:02 +0900
committerAkinori Hattori <hattya@gentoo.org>2020-08-20 22:27:02 +0900
commitc76d8f2283b24bedcdcf7d478412adc6db54bdb2 (patch)
tree465212608195b7486cae4ea699609801f9794e89
parentapp-emulation/virt-manager: Stabilize 2.2.1-r3 arm64, #738076 (diff)
downloadgentoo-c76d8f2283b24bedcdcf7d478412adc6db54bdb2.tar.gz
gentoo-c76d8f2283b24bedcdcf7d478412adc6db54bdb2.tar.bz2
gentoo-c76d8f2283b24bedcdcf7d478412adc6db54bdb2.zip
app-i18n/canfep: respect CXXFLAGS
Closes: https://bugs.gentoo.org/734236 Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Akinori Hattori <hattya@gentoo.org>
-rw-r--r--app-i18n/canfep/canfep-1.0-r1.ebuild3
-rw-r--r--app-i18n/canfep/canfep-1.0.ebuild3
2 files changed, 4 insertions, 2 deletions
diff --git a/app-i18n/canfep/canfep-1.0-r1.ebuild b/app-i18n/canfep/canfep-1.0-r1.ebuild
index c78e54ada07f..47db7408be3d 100644
--- a/app-i18n/canfep/canfep-1.0-r1.ebuild
+++ b/app-i18n/canfep/canfep-1.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
@@ -36,6 +36,7 @@ src_prepare() {
src_compile() {
emake \
CC="$(tc-getCXX)" \
+ CFLAGS="${CXXFLAGS}" \
LIBS="-lcanna $($(tc-getPKG_CONFIG) --libs ncurses)"
}
diff --git a/app-i18n/canfep/canfep-1.0.ebuild b/app-i18n/canfep/canfep-1.0.ebuild
index a290748825da..318da4e89440 100644
--- a/app-i18n/canfep/canfep-1.0.ebuild
+++ b/app-i18n/canfep/canfep-1.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
@@ -30,6 +30,7 @@ src_prepare() {
src_compile() {
emake \
CC="$(tc-getCXX)" \
+ CFLAGS="${CXXFLAGS}" \
LIBS="-lcanna $(pkg-config --libs ncurses)"
}