summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2018-06-29 18:17:11 -0500
committerBen Kohler <bkohler@gentoo.org>2018-06-29 18:17:11 -0500
commite6f094a16ed97dd5c316d4bd1085d3076245d9fe (patch)
tree79c1f073b57244efa143710c87644ff061cf7b45 /app-admin/ps_mem
parentnet-wireless/unifi: bump to 5.8.24 (diff)
downloadgentoo-e6f094a16ed97dd5c316d4bd1085d3076245d9fe.tar.gz
gentoo-e6f094a16ed97dd5c316d4bd1085d3076245d9fe.tar.bz2
gentoo-e6f094a16ed97dd5c316d4bd1085d3076245d9fe.zip
app-admin/ps_mem: revbump for python-single-r1 & minor tweaks
Package-Manager: Portage-2.3.41, Repoman-2.3.9
Diffstat (limited to 'app-admin/ps_mem')
-rw-r--r--app-admin/ps_mem/ps_mem-3.12-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-admin/ps_mem/ps_mem-3.12-r1.ebuild b/app-admin/ps_mem/ps_mem-3.12-r1.ebuild
new file mode 100644
index 000000000000..82174961a3b7
--- /dev/null
+++ b/app-admin/ps_mem/ps_mem-3.12-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_5,3_6} )
+DISTUTILS_SINGLE_IMPL=1
+inherit distutils-r1
+
+DESCRIPTION="A utility to report core memory usage per program"
+HOMEPAGE="https://github.com/pixelb/${PN}"
+SRC_URI="https://github.com/pixelb/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_install() {
+ distutils-r1_python_install --install-scripts="${EPREFIX}/usr/sbin"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ doman ${PN}.1
+}