summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2024-03-22 12:05:37 -0400
committerMichael Orlitzky <mjo@gentoo.org>2024-03-22 12:09:42 -0400
commit28ac4fb74f30b0f24b7de3b3727da20e7d5088aa (patch)
tree1f2f1f38ec8f66d219544533b4348914b641d71a /app-admin
parentgui-libs/gtk-layer-shell: Stabilize 0.8.2 ppc64, #925293 (diff)
downloadgentoo-28ac4fb74f30b0f24b7de3b3727da20e7d5088aa.tar.gz
gentoo-28ac4fb74f30b0f24b7de3b3727da20e7d5088aa.tar.bz2
gentoo-28ac4fb74f30b0f24b7de3b3727da20e7d5088aa.zip
app-admin/drush: new revision to fix method signatures again
Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/drush/drush-6.7.0-r7.ebuild68
-rw-r--r--app-admin/drush/files/drush-6.7.0-batch-signature-fix-r1.patch46
2 files changed, 114 insertions, 0 deletions
diff --git a/app-admin/drush/drush-6.7.0-r7.ebuild b/app-admin/drush/drush-6.7.0-r7.ebuild
new file mode 100644
index 000000000000..1329345e4dc0
--- /dev/null
+++ b/app-admin/drush/drush-6.7.0-r7.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit bash-completion-r1
+
+DESCRIPTION="Command line shell and scripting interface for Drupal"
+HOMEPAGE="https://github.com/drush-ops/drush"
+SRC_URI="https://github.com/drush-ops/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-lang/php[cli,ctype,json(+),simplexml]
+ dev-php/PEAR-Console_Table"
+
+PATCHES=(
+ "${FILESDIR}/update-bash-completion-script-for-2.1.patch"
+ "${FILESDIR}/array-syntax.patch"
+ "${FILESDIR}/${P}-php8.0.patch"
+ "${FILESDIR}/${P}-gzip-mime.patch"
+ "${FILESDIR}/${P}-dont-pass-null-to-strtoupper.patch"
+ "${FILESDIR}/${P}-batch-signature-fix-r1.patch"
+)
+
+src_prepare() {
+ default
+
+ # dodoc compresses all of the documentation, so we fix the filenames
+ # in a few places.
+ #
+ # First, the README location in bootstrap.inc.
+ sed -i -e \
+ "s!/share/doc/drush!/share/doc/${PF}!" \
+ -e "s!README\.md!\0.bz2!g" \
+ includes/bootstrap.inc || die
+
+ # Next, the list of documentation in docs.drush.inc. Note that
+ # html files don't get compressed.
+ sed -i \
+ -e "s!\.bashrc'!.bashrc.bz2'!" \
+ -e "s!\.inc'!.inc.bz2'!" \
+ -e "s!\.ini'!.ini.bz2'!" \
+ -e "s!\.md'!.md.bz2'!" \
+ -e "s!\.php'!.php.bz2'!" \
+ -e "s!\.script'!.script.bz2'!" \
+ -e "s!\.txt'!.txt.bz2'!" \
+ commands/core/docs.drush.inc || die
+}
+
+src_install() {
+ # Always install the examples; they're referenced within the source
+ # code and too difficult to exorcise.
+ dodoc -r README.md docs examples
+
+ insinto /usr/share/drush
+ doins -r classes commands includes lib misc
+ doins drush_logo-black.png drush.info drush.php
+
+ exeinto /usr/share/drush
+ doexe drush
+ dosym ../share/drush/drush /usr/bin/drush
+
+ keepdir /etc/drush
+ newbashcomp drush.complete.sh drush
+}
diff --git a/app-admin/drush/files/drush-6.7.0-batch-signature-fix-r1.patch b/app-admin/drush/files/drush-6.7.0-batch-signature-fix-r1.patch
new file mode 100644
index 000000000000..14ee72b7dc4a
--- /dev/null
+++ b/app-admin/drush/files/drush-6.7.0-batch-signature-fix-r1.patch
@@ -0,0 +1,46 @@
+From 1acd52cff0d516ebfa7f177c38ed7f851c4f472a Mon Sep 17 00:00:00 2001
+From: Michael Orlitzky <michael@orlitzky.com>
+Date: Wed, 16 Aug 2023 21:21:39 -0400
+Subject: [PATCH] includes/batch.inc: synchronize sub and superclass signatures
+
+The DrushBatchContext class overrides the offsetSet() method of its
+superclass, ArrayObject, but changes its signature:
+
+ Error: Return type of DrushBatchContext::offsetSet($name, $value)
+ should either be compatible with ArrayObject::offsetSet(mixed $key,
+ mixed $value): void, or the #[\ReturnTypeWillChange] attribute should
+ be used to temporarily suppress the notice in .../batch.inc, line 37
+
+Renaming the parameter to $key and adding type hints fixes the issue.
+
+Signed-off-by: Michael Orlitzky <michael@orlitzky.com>
+---
+ includes/batch.inc | 8 ++++----
+ 1 file changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/includes/batch.inc b/includes/batch.inc
+index dd4adc9..d26fabb 100644
+--- a/includes/batch.inc
++++ b/includes/batch.inc
+@@ -34,14 +34,14 @@
+ * @see _drush_batch_worker().
+ */
+ class DrushBatchContext extends ArrayObject {
+- function offsetSet($name, $value) {
+- if ($name == 'message') {
++ function offsetSet(mixed $key, mixed $value): void {
++ if ($key == 'message') {
+ drush_log(strip_tags($value), 'ok');
+ }
+- elseif ($name == 'error_message') {
++ elseif ($key == 'error_message') {
+ drush_set_error('DRUSH_BATCH_ERROR', strip_tags($value));
+ }
+- parent::offsetSet($name, $value);
++ parent::offsetSet($key, $value);
+ }
+ }
+
+--
+2.43.2
+