summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2017-09-04 21:50:09 +0200
committerJohannes Huber <johu@gentoo.org>2017-09-04 21:50:48 +0200
commitbbbe001072a0401be6fd88f4cbde72aeff3e560f (patch)
tree53982e69bc73bd3ebc7a96986ac8b0f1f54dad53 /app-admin
parentnet-dns/pdns: add libressl support (diff)
downloadgentoo-bbbe001072a0401be6fd88f4cbde72aeff3e560f.tar.gz
gentoo-bbbe001072a0401be6fd88f4cbde72aeff3e560f.tar.bz2
gentoo-bbbe001072a0401be6fd88f4cbde72aeff3e560f.zip
app-admin/calamares: Version bump 3.1.3
Gentoo-bug: 628740 Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/calamares/Manifest1
-rw-r--r--app-admin/calamares/calamares-3.1.3.ebuild80
2 files changed, 81 insertions, 0 deletions
diff --git a/app-admin/calamares/Manifest b/app-admin/calamares/Manifest
index 5641d7b840e4..123d1e83db3f 100644
--- a/app-admin/calamares/Manifest
+++ b/app-admin/calamares/Manifest
@@ -1 +1,2 @@
DIST calamares-3.1.1.tar.gz 4895018 SHA256 1644f28f0ee166411dafc849d1d1c9b5bf4f7346ebaf430ee3cf1a7d330a85aa SHA512 4c45f949075a46c6b1de14b322f7d124b4346b11c112b410a216359530d055d21ae8357609d2279614da5490f72f38aebf7844942a2e8a8c2a244cf31350720c WHIRLPOOL 8be229cdcbea88c396a98f42232b0dcb30df81895f927ef45c815be618f5d094f85e2b0fdda7cdf93d6a953d785a7c45bd3f0eae70d2e8775a0bccb8d0a19b3e
+DIST calamares-3.1.3.tar.gz 4944637 SHA256 9a43dbe465f64f3f286bd13d2eea6a6cb790a561cf477521ae7dc54d49298c17 SHA512 2a8e38234b60aaf8f82cf146e79c364055485a3a50f385d7ff6744df973a67de390223a8fa7e3b5ffb854f997cd0de7e93c1c912dd5739d56dca92528d9522c0 WHIRLPOOL 524ef6dc5528e83ecad4d98f8d7ebb4398f50d683c30c13c4b2aeba1797d3aa725158e80b3a3d25fd6d2071a579882231b78f56f9f2bb1fdf46a3cbb88d10713
diff --git a/app-admin/calamares/calamares-3.1.3.ebuild b/app-admin/calamares/calamares-3.1.3.ebuild
new file mode 100644
index 000000000000..780fcfe4fd0f
--- /dev/null
+++ b/app-admin/calamares/calamares-3.1.3.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{3_4,3_5} )
+inherit kde5 python-r1
+
+DESCRIPTION="Distribution-independent installer framework"
+HOMEPAGE="https://calamares.io"
+if [[ ${KDE_BUILD_TYPE} == live ]] ; then
+ EGIT_REPO_URI="https://github.com/${PN}/${PN}"
+else
+ SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-3"
+IUSE="+networkmanager pythonqt +upower"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kparts)
+ $(add_frameworks_dep kservice)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtsvg)
+ $(add_qt_dep qtwebengine 'widgets')
+ $(add_qt_dep qtwidgets)
+ >=dev-cpp/yaml-cpp-0.5.1
+ >=dev-libs/boost-1.55:=[${PYTHON_USEDEP}]
+ sys-apps/dbus
+ sys-apps/dmidecode
+ sys-auth/polkit-qt[qt5(+)]
+ >=sys-libs/kpmcore-3.0.3:5=
+ pythonqt? ( >=dev-python/PythonQt-3.1:=[${PYTHON_USEDEP}] )
+"
+
+RDEPEND="${DEPEND}
+ app-admin/sudo
+ dev-libs/libatasmart
+ net-misc/rsync
+ >=sys-block/parted-3.0
+ || ( sys-boot/grub:2 sys-boot/systemd-boot )
+ sys-boot/os-prober
+ sys-fs/squashfs-tools
+ virtual/udev
+ networkmanager? ( net-misc/networkmanager )
+ upower? ( sys-power/upower )
+"
+
+src_prepare() {
+ python_setup
+ export PYTHON_INCLUDE_DIRS="$(python_get_includedir)" \
+ PYTHON_INCLUDE_PATH="$(python_get_library_path)"\
+ PYTHON_CFLAGS="$(python_get_CFLAGS)"\
+ PYTHON_LIBS="$(python_get_LIBS)"
+
+ eapply_user
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DWEBVIEW_FORCE_WEBKIT=OFF
+ -DWITH_PYTHONQT=$(usex pythonqt)
+ )
+
+ kde5_src_configure
+ sed -i -e 's:pkexec /usr/bin/calamares:calamares-pkexec:' "${S}"/calamares.desktop
+ sed -i -e 's:Icon=calamares:Icon=drive-harddisk:' "${S}"/calamares.desktop
+}
+
+src_install() {
+ kde5_src_install
+ dobin "${FILESDIR}"/calamares-pkexec
+}