summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2025-02-15 07:17:46 +0100
committerMichał Górny <mgorny@gentoo.org>2025-02-15 08:01:02 +0100
commitd4ff3e96239729e5fda90b377a53692073955cc4 (patch)
treeb43fa1517daa02247288c5c3c65605efa3eddeb5 /app-admin
parentdev-python/uv: Bump to 0.6.0 (diff)
downloadgentoo-d4ff3e96239729e5fda90b377a53692073955cc4.tar.gz
gentoo-d4ff3e96239729e5fda90b377a53692073955cc4.tar.bz2
gentoo-d4ff3e96239729e5fda90b377a53692073955cc4.zip
app-admin/awscli: Bump to 1.37.21
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.37.21.ebuild95
2 files changed, 96 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index 51a3af44635c..175d93f9c2fa 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -4,4 +4,5 @@ DIST aws-cli-1.37.17.gh.tar.gz 2903616 BLAKE2B a3c3001dd4d4bc4051890bdeaf4012bd6
DIST aws-cli-1.37.18.gh.tar.gz 2904282 BLAKE2B 2f1f62dfe2737a42d4d1d3e969462a02bd7f619aa11a31ad723546bd780c66e8f9a17afd7b82af0b67915ba6ff326e7dc1ae396a2f8670c20e57462f137119a0 SHA512 7d4dcc0619cb215d6c49c4d2b45cc3a7919a05bcc246b70d774a960a23a1689ce201aa3be0737324d8b727acb04d39a1ea952c0214b7797bc458be47cfbfd012
DIST aws-cli-1.37.19.gh.tar.gz 2905629 BLAKE2B 0d5027985f4d9da2897a000d10ea6b75e2ae70da87c7f9e494305cc745f5146cf02ed0e35d34cd7a0ca041ab64db95e79e0fc0f8b7030598d7375dbebc43f557 SHA512 525787e13e864df51fc3b86c35dedbdea5d5cacfdc384f5c536aca44f54b83590cc7adb3a05921445a43a133c4ecf837fed341bfb841c539ad62f69f07a992f9
DIST aws-cli-1.37.20.gh.tar.gz 2906150 BLAKE2B cd934eae7267a8a7cb83bb4e79f53a78b34e2f9391973e7b9aa092b0d2e7ee882cab3cae06f93e6de9645ebf92f27944cfde0a6facb0aa92f6057d236d309f5a SHA512 b3ca3073e5c4e815e5a6c343e8cb896f96510163535b89dc171251779f5fd7cd21cbcba086f541bc721d8343c2a5271a84776a2b3f7cb1c03a84b1ee0fdbdd56
+DIST aws-cli-1.37.21.gh.tar.gz 2907762 BLAKE2B e42e9aed28ef3cee1b83f2e57f90ce81a9894bc23a960fef487096ce8b8bab16d23121658aed0547070919ae78a0476176f9517d583a84be90bb016c7cdd9bf7 SHA512 3c7b347627b799d7a3edc7a8cae3d6110ec3cc5bfcdecc247876135faebc2235546a514afbdaf95fec50cfe787ca30b125cae7a8e7be84134d83493a0f869b1a
DIST aws-cli-1.37.6.gh.tar.gz 2896548 BLAKE2B c160d981fc9d2a9c3de69b6d7dfc9fc699ad9ebbd7bd81808a74371059362ee7616a00c1c4d61674f4d9e8ebb35c3047c11d43c8c4bbf4ad63e65771462cc556 SHA512 475637e353afef4177d9375f2b8f9c86732ff55040ee1dfdc307a5c7fb6392db983e75324ebabe8016fb5c8712c1433a194a0cff65eda1f930a86b9357aafe28
diff --git a/app-admin/awscli/awscli-1.37.21.ebuild b/app-admin/awscli/awscli-1.37.21.ebuild
new file mode 100644
index 000000000000..4a8e0ae852e0
--- /dev/null
+++ b/app-admin/awscli/awscli-1.37.21.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit bash-completion-r1 distutils-r1
+
+MY_P=aws-cli-${PV}
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="
+ https://github.com/aws/aws-cli/
+ https://pypi.org/project/awscli/
+"
+SRC_URI="
+ https://github.com/aws/aws-cli/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+# botocore is x.(y-1).z
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) - 1)).$(ver_cut 3-)"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.11.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ !app-admin/awscli-bin
+"
+BDEPEND="
+ test? (
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local serial_tests=(
+ tests/functional/ecs/test_execute_command.py::TestExecuteCommand::test_execute_command_success
+ tests/functional/ssm/test_start_session.py::TestSessionManager::test_start_session_{fails,success}
+ tests/functional/ssm/test_start_session.py::TestSessionManager::test_start_session_with_new_version_plugin_success
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking_windows
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestNuGetLogin::test_login_nuget_sources_listed_with_backtracking
+ tests/unit/customizations/ecs/test_executecommand_startsession.py::TestExecuteCommand::test_execute_command_success
+ tests/unit/customizations/test_sessionmanager.py
+ tests/unit/test_compat.py::TestIgnoreUserSignals
+ tests/unit/test_help.py
+ tests/unit/test_utils.py::TestIgnoreCtrlC::test_ctrl_c_is_ignored
+ )
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ EPYTEST_XDIST= epytest "${serial_tests[@]}"
+
+ local EPYTEST_DESELECT=(
+ "${serial_tests[@]}"
+
+ # flaky (some ordering?)
+ tests/functional/s3/test_cp_command.py::TestCPCommand::test_multipart_upload_with_checksum_algorithm_crc32
+ )
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit}
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}