summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Vaněk <arkamar@gentoo.org>2025-01-26 09:46:52 +0100
committerPetr Vaněk <arkamar@gentoo.org>2025-01-26 09:47:31 +0100
commit031fe20e9e68b0f461470d8ef259df4d23d363d4 (patch)
treedc71a1527184fabc0310006d67bf770778ece69d /app-backup/borgmatic
parentdev-java/bcpg: add 1.80 (diff)
downloadgentoo-031fe20e9e68b0f461470d8ef259df4d23d363d4.tar.gz
gentoo-031fe20e9e68b0f461470d8ef259df4d23d363d4.tar.bz2
gentoo-031fe20e9e68b0f461470d8ef259df4d23d363d4.zip
app-backup/borgmatic: add 1.9.8
Signed-off-by: Petr Vaněk <arkamar@gentoo.org>
Diffstat (limited to 'app-backup/borgmatic')
-rw-r--r--app-backup/borgmatic/Manifest1
-rw-r--r--app-backup/borgmatic/borgmatic-1.9.8.ebuild84
2 files changed, 85 insertions, 0 deletions
diff --git a/app-backup/borgmatic/Manifest b/app-backup/borgmatic/Manifest
index cbe6754a9eb7..59bec598eeec 100644
--- a/app-backup/borgmatic/Manifest
+++ b/app-backup/borgmatic/Manifest
@@ -2,3 +2,4 @@ DIST borgmatic-1.9.4.tar.gz 635562 BLAKE2B aac7cea7c7b9537a1f13f6cdd5fc15c3a7d43
DIST borgmatic-1.9.5.tar.gz 638074 BLAKE2B 9947a443bcdd04abe29a3eaf3f790491cddc8283d6e09b56cb3b2aed97e0a424e0251aa9b19b3b5687416f59dec2944ed6d41c99df6e7790fa54a5b2608af0bf SHA512 9ab23865aeef61399a85532450cf7c9bc853a95560d383c83d43966eba0a66718976abdfcb2feec104c8941c0acd5406e2f1812be31b0f4baa76caf6a8ae81c9
DIST borgmatic-1.9.6.tar.gz 640257 BLAKE2B 6d95fe1d12fa401b25d00187a20520003ebc05ceb481add6c0706fcc6bb40f275830cd35f3fa90ea3680457e93a33bf21abb7f3d6423c9268c95b4e356587fdc SHA512 ff2050dcde579e5dffeef915bead5672158387c9a883d9f5b996ba8e804e37d9445b07839f84959cae2b367735f742cab83e143b363cedbb61f38621e2b0a95b
DIST borgmatic-1.9.7.tar.gz 641880 BLAKE2B 747046bfbd860330b892bcdff247c1a61893bc9f08e16e039a8659229017c0faac4a16be69dd5bd9c871b1655018ed6b36a1bf7a289d917b268ebdc4035a4482 SHA512 bdc55ca75cae6d5224742508bc201dd97ffabfc590c6f21282a20cb28e2f16100175300c9bbf4f6c874779ca577f2a6141c0cc8aa0622f0ca1ebf1255ab65060
+DIST borgmatic-1.9.8.tar.gz 642464 BLAKE2B 0473e440d8beb99adac1fcf6c3628f12ca1b9b4337190eaac5aa6cb4726a2be9ada56f1a25be9369cf5a36e5bd53bf2070c2f1579c96bc7375cf5f184a7129af SHA512 a4c524ddddae99d4a244e6d6d7c8d91ea980b29267b2bca8c8dcf45087fa70039088c225a5144e072e5453a76dfbdca61f7718eba4c558d94226222574e9e09a
diff --git a/app-backup/borgmatic/borgmatic-1.9.8.ebuild b/app-backup/borgmatic/borgmatic-1.9.8.ebuild
new file mode 100644
index 000000000000..dea28ebb55e3
--- /dev/null
+++ b/app-backup/borgmatic/borgmatic-1.9.8.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..13} )
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 systemd pypi
+
+DESCRIPTION="Automatically create, prune and verify backups with borgbackup"
+HOMEPAGE="
+ https://torsion.org/borgmatic/
+ https://projects.torsion.org/borgmatic-collective/borgmatic
+"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv"
+IUSE="apprise"
+
+# borg is called as an external tool, hence no pythonic stuff
+RDEPEND="
+ app-backup/borgbackup
+ $(python_gen_cond_dep '
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/ruamel-yaml[${PYTHON_USEDEP}]
+ ')
+ apprise? ( $(python_gen_cond_dep '
+ dev-python/apprise[${PYTHON_USEDEP}]
+ ') )
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ $(python_gen_cond_dep '
+ dev-python/apprise[${PYTHON_USEDEP}]
+ >=dev-python/flexmock-0.10.10[${PYTHON_USEDEP}]
+ ')
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.7.14-systemd_service_bin_path.patch
+ "${FILESDIR}"/${PN}-1.9.3-no_test_coverage.patch
+)
+
+EPYTEST_DESELECT=(
+ # A fragile test whose only purpose is to make sure the NEWS file
+ # has been updated for the current version.
+ tests/integration/commands/test_borgmatic.py::test_borgmatic_version_matches_news_version
+)
+
+distutils_enable_tests pytest
+
+src_install() {
+ distutils-r1_src_install
+ systemd_dounit sample/systemd/borgmatic.{service,timer}
+ keepdir /etc/borgmatic
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ elog "To generate a sample configuration file, run:"
+ elog " ${PN} config generate"
+ elog
+ elog "Systemd users wishing to periodically run ${PN} can use the provided timer and service units."
+ else
+ local oldver
+ for oldver in ${REPLACING_VERSIONS}; do
+ if ver_test "${oldver}" -lt 1.9.0; then
+ ewarn "Please be warned that ${PN}-1.9.0 has introduced several breaking changes."
+ ewarn "For details, please see"
+ ewarn
+ ewarn " https://github.com/borgmatic-collective/borgmatic/releases/tag/1.9.0"
+ ewarn
+ break
+ fi
+ done
+ fi
+}