summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-01-16 19:10:56 +0100
committerDavid Seifert <soap@gentoo.org>2016-01-16 19:12:43 +0100
commit7ad37bafddeffa38becb83a2609eef5c64791bca (patch)
tree6f30835b9923d2fa474955524cba0b9132e31ca0 /app-benchmarks/contest/contest-0.61-r1.ebuild
parentsys-fs/sshfs-fuse: remove old (diff)
downloadgentoo-7ad37bafddeffa38becb83a2609eef5c64791bca.tar.gz
gentoo-7ad37bafddeffa38becb83a2609eef5c64791bca.tar.bz2
gentoo-7ad37bafddeffa38becb83a2609eef5c64791bca.zip
app-benchmarks/contest: add -std=gnu89 to CFLAGS to restore pre-GCC5 semantics
Gentoo-Bug: 570250 In addition, modernize to EAPI=6 and amend patches accordingly. Package-Manager: portage-2.2.26
Diffstat (limited to 'app-benchmarks/contest/contest-0.61-r1.ebuild')
-rw-r--r--app-benchmarks/contest/contest-0.61-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-benchmarks/contest/contest-0.61-r1.ebuild b/app-benchmarks/contest/contest-0.61-r1.ebuild
new file mode 100644
index 000000000000..27bf44b5d294
--- /dev/null
+++ b/app-benchmarks/contest/contest-0.61-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="Test system responsiveness to compare different kernels"
+HOMEPAGE="http://members.optusnet.com.au/ckolivas/contest/"
+SRC_URI="http://members.optusnet.com.au/ckolivas/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND=">=app-benchmarks/dbench-2.0"
+PATCHES=(
+ "${FILESDIR}/${PN}-fortify_sources.patch"
+ "${FILESDIR}/${P}-fix-buildsystem.patch"
+)
+
+src_prepare () {
+ # fix #570250 by restoring pre-GCC5 inline semantics
+ append-cflags -std=gnu89
+
+ default
+ tc-export CC
+}
+src_compile() {
+ emake
+}
+
+src_install() {
+ dobin contest
+ doman contest.1
+ dodoc README
+}