summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2024-08-18 20:23:58 -0700
committerZac Medico <zmedico@gentoo.org>2024-08-18 20:29:15 -0700
commit7cbcd50c9c409581992d7c7ee2f3c2b82e2f6c6f (patch)
treed65d74903f656b5da909a0789b8f75a3a894c1ff /app-containers
parentmedia-gfx/ueberzugpp: improve libc++ check (diff)
downloadgentoo-7cbcd50c9c409581992d7c7ee2f3c2b82e2f6c6f.tar.gz
gentoo-7cbcd50c9c409581992d7c7ee2f3c2b82e2f6c6f.tar.bz2
gentoo-7cbcd50c9c409581992d7c7ee2f3c2b82e2f6c6f.zip
app-containers/k3d: add 5.7.3 (bump K3S_TAG to v1.30.3-k3s1)
Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'app-containers')
-rw-r--r--app-containers/k3d/Manifest1
-rw-r--r--app-containers/k3d/k3d-5.7.3.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/app-containers/k3d/Manifest b/app-containers/k3d/Manifest
index 536b64890a4f..b3995d3253af 100644
--- a/app-containers/k3d/Manifest
+++ b/app-containers/k3d/Manifest
@@ -1,2 +1,3 @@
DIST k3d-5.4.9.tar.gz 7740293 BLAKE2B b7a657720524abac2c36cccef8cf6e9c5588fcc191ecc2a3f7ed138762cc23abdc2b6413c67d426635e50777b8b87fccf93dc7cd88b0dd5c67becbc3f9056472 SHA512 caa6566f79837deb31db991df5475369b4921a5a110b723ad6c76f8ce2349399d0843d3e5de071a4ec50b318157d8fb47cc36018a0af9bb487793269c27027bf
DIST k3d-5.6.0.tar.gz 8022281 BLAKE2B 93f32f65e6c42650608b94d58d2149c3fec96251500be0d95d5673f07ae8c366d80954afa4d80eec149b7a9e8af7389323c21498910a3010bb80b975f64064d0 SHA512 c13df93499ffde6567e4bf7dcf260cb65ca01c390bf39361122fa61553591f418213049cf29d8dde63896f026a28d96f4e2ab522a143ac66cfa9f3786f8ba9b9
+DIST k3d-5.7.3.tar.gz 9566684 BLAKE2B 9dff7ab447b3fd790a036d61bc3a4bb61238c74eec60aa12a4ff10150ff2f4999a3b1e635aaae6211f4e05ed9c589dc08e08ba511eb7690f857c0dad954b6ce7 SHA512 d6e2f6fb3013429745e1663214c7dd66dd2727b592a32e81f5837bbcc997aee18418366a0e21463ba48a2d72b9a86067f492f1f44c4689a129166dcf018e5642
diff --git a/app-containers/k3d/k3d-5.7.3.ebuild b/app-containers/k3d/k3d-5.7.3.ebuild
new file mode 100644
index 000000000000..1a19ed584ac4
--- /dev/null
+++ b/app-containers/k3d/k3d-5.7.3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+
+DESCRIPTION="k3d creates k3s clusters in docker"
+HOMEPAGE="https://github.com/rancher/k3d"
+
+K3D_K3S_TAG=v1.30.3-k3s1
+SRC_URI="https://github.com/rancher/k3d/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="MIT Apache-2.0 BSD BSD-2 MPL-2.0 ISC"
+SLOT="0"
+
+KEYWORDS="~amd64"
+IUSE="doc"
+
+src_prepare() {
+ default
+ rm Makefile || die
+}
+
+src_compile() {
+ local extra_ldflags=(
+ -X "github.com/k3d-io/k3d/v5/version.Version=v${PV}"
+ -X "github.com/k3d-io/k3d/v5/version.K3sVersion=${K3D_K3S_TAG}"
+ )
+ env -u GOWORK \
+ CGO_ENABLED=0 \
+ go build \
+ -mod=vendor \
+ -ldflags "-w -s ${extra_ldflags[*]}" \
+ -o bin/k3d || die
+}
+
+src_install() {
+ dobin bin/${PN}
+ DOCS=(*.md)
+ if use doc; then
+ DOCS+=(docs)
+ fi
+ default_src_install
+}