summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2021-02-26 02:27:42 +0100
committerSebastian Pipping <sping@gentoo.org>2021-02-26 02:27:42 +0100
commitb7e10c520c4128d399f48d0bba24634e4ef5d3e1 (patch)
tree0d9336517b75640612ae1c5b3eeef1b2fbb1d065 /app-crypt/debian-archive-keyring/debian-archive-keyring-2021.1.1.ebuild
parentapp-admin/vault: Bump to version 1.6.3 (diff)
downloadgentoo-b7e10c520c4128d399f48d0bba24634e4ef5d3e1.tar.gz
gentoo-b7e10c520c4128d399f48d0bba24634e4ef5d3e1.tar.bz2
gentoo-b7e10c520c4128d399f48d0bba24634e4ef5d3e1.zip
app-crypt/debian-archive-keyring: 2021.1.1
Signed-off-by: Sebastian Pipping <sping@gentoo.org> Package-Manager: Portage-3.0.14, Repoman-3.0.2
Diffstat (limited to 'app-crypt/debian-archive-keyring/debian-archive-keyring-2021.1.1.ebuild')
-rw-r--r--app-crypt/debian-archive-keyring/debian-archive-keyring-2021.1.1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-crypt/debian-archive-keyring/debian-archive-keyring-2021.1.1.ebuild b/app-crypt/debian-archive-keyring/debian-archive-keyring-2021.1.1.ebuild
new file mode 100644
index 000000000000..bbf259a150b6
--- /dev/null
+++ b/app-crypt/debian-archive-keyring/debian-archive-keyring-2021.1.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit unpacker
+
+DESCRIPTION="GnuPG archive keys of the Debian archive"
+HOMEPAGE="https://packages.debian.org/sid/debian-archive-keyring"
+SRC_URI="mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${PV}_all.deb"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE=""
+
+S="${WORKDIR}"
+
+src_install() {
+ doins -r .
+
+ # https://bugs.gentoo.org/729142
+ gunzip "${D}"/usr/share/doc/${PN}/changelog.gz || die
+
+ mv "${D}"/usr/share/doc/{${PN},${PF}} || die
+}