summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorcharIes17 <charles17@arcor.de>2017-08-03 09:14:43 +0200
committerPatrice Clement <monsieurp@gentoo.org>2017-08-04 08:22:13 +0200
commitcada6eaa63e82a908cb06a863b5e4252973f1ff8 (patch)
treee21c7859571d9af4f44fba70de705b916b0c30cd /app-forensics
parentdev-ruby/rails: add rails 5.0.5 (diff)
downloadgentoo-cada6eaa63e82a908cb06a863b5e4252973f1ff8.tar.gz
gentoo-cada6eaa63e82a908cb06a863b5e4252973f1ff8.tar.bz2
gentoo-cada6eaa63e82a908cb06a863b5e4252973f1ff8.zip
app-forensics/lynis: version bump to 2.5.2.
Gentoo-Bug: https://bugs.gentoo.org/621266 Gentoo-Bug: https://bugs.gentoo.org/591262 Package-Manager: Portage-2.3.6, Repoman-2.3.1 Closes: https://github.com/gentoo/gentoo/pull/5281
Diffstat (limited to 'app-forensics')
-rw-r--r--app-forensics/lynis/Manifest1
-rw-r--r--app-forensics/lynis/lynis-2.5.2.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/app-forensics/lynis/Manifest b/app-forensics/lynis/Manifest
index 0bc05dbaab3c..5c2e0649f096 100644
--- a/app-forensics/lynis/Manifest
+++ b/app-forensics/lynis/Manifest
@@ -1,3 +1,4 @@
DIST lynis-1.6.4.tar.gz 171953 SHA256 886c74b591706f896149fe74adb481b58c549d32243d0cf620b46dfdd25dc66d SHA512 d0e102e4aac985460125dc26527e7902e9465e844c35253da7cc84e4c8fa19445e4b0b01d0db0b9e0f09c1929839aed33cf4b93f43c3be61490bcf11e2bbfa4b WHIRLPOOL 98275f8b014b70160e83ec6ddf0cdeec8a0e9ef78cc9dedf842a6524dabe3f44c7a42cf787d1180241a9122365cb2e1e908eedf05eab1768237fdb34322790bd
DIST lynis-2.1.0.tar.gz 180493 SHA256 16ed596c8c283b8e4c635ada25ceb042371384ae09b3238a658ca60801a73c24 SHA512 724c9d8d619d05a893197ff5e891056db3e6d4e03a59514499de0fda9134d2387c7c31c8e16fd58d7f3c1de9ce4c00df8f48679e1e27194dbcf6d34f6be94e62 WHIRLPOOL f50c32e36ab6b31bf4f1851e9b77c3f59d08b9f609bdb48c442603e21d61547483a0620de07fbd837c4ed6ffd9fc697e9b4cfcc40c970df9568de9da91e3fb7f
DIST lynis-2.1.1.tar.gz 181099 SHA256 d17b3cbbd305c52b9cd0d5141f41954882f398db44f26c10cb45fdaaa46a99d2 SHA512 03e694611b77cade352972360bd768355b945cf0919e445cb91eaa9801ab7501e533400c7a5b6912720fde0a90db47c3365c1f1c52aef41d84e32d6bbef8bf26 WHIRLPOOL 05a700425b94488ad1078a9c90093a4b250b7233d958183c57531f73b5431fbfb7aff315849c6451a8c2016f68018141917c3502a9cd3f1a2a41f09575ede8cd
+DIST lynis-2.5.2.tar.gz 264098 SHA256 6b4dc74ec0faa009fc5d34f8ab85895e53c6f4f02bc160377905dcb95b0585a1 SHA512 dc9b994190f5a6102baaf1c4d226ee90980a32908c009a9f68bb9e716e0ba04063d51f3cca98b9538f6b30224097470ca3d484b667f2af73b922c0b239f4bdae WHIRLPOOL 6d4bfa2171b671932f39e006aa3ee249f0a1e3014266ea0152193217a0780630fbe89c886353142216eac8e8396ebde4ba8428377f0b06d22e897876e2ac27f6
diff --git a/app-forensics/lynis/lynis-2.5.2.ebuild b/app-forensics/lynis/lynis-2.5.2.ebuild
new file mode 100644
index 000000000000..80b80fe374ab
--- /dev/null
+++ b/app-forensics/lynis/lynis-2.5.2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+inherit eutils bash-completion-r1
+
+DESCRIPTION="Security and system auditing tool"
+HOMEPAGE="https://cisofy.com/lynis/"
+SRC_URI="https://cisofy.com/files/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="app-shells/bash"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ # Bug 507438
+ epatch_user
+}
+
+src_install() {
+ doman lynis.8
+ dodoc FAQ README
+ newdoc CHANGELOG.md CHANGELOG
+
+ # Remove the old one during the next stabilize progress
+ exeinto /etc/cron.daily
+ newexe "${FILESDIR}"/lynis.cron-new lynis
+
+ dobashcomp extras/bash_completion.d/lynis
+
+ # stricter default perms - bug 507436
+ diropts -m0700
+ insopts -m0600
+
+ insinto /usr/share/${PN}
+ doins -r db/ include/ plugins/
+
+ dosbin lynis
+
+ insinto /etc/${PN}
+ doins default.prf
+}
+
+pkg_postinst() {
+ einfo
+ einfo "A cron script has been installed to ${ROOT}etc/cron.daily/lynis."
+ einfo
+}