summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2020-12-07 00:00:00 +0000
committerMike Gilbert <floppym@gentoo.org>2020-12-07 13:14:25 -0500
commit0b3e5c8833c1632cb5bcfce3d1c20f8d133862bd (patch)
treee5aa6ee1ae4b480778c74462ba631b22252f7fb3 /app-i18n/fcitx
parentprofiles/prefix/darwin/macos/11.0: unmask bash, readline again (diff)
downloadgentoo-0b3e5c8833c1632cb5bcfce3d1c20f8d133862bd.tar.gz
gentoo-0b3e5c8833c1632cb5bcfce3d1c20f8d133862bd.tar.bz2
gentoo-0b3e5c8833c1632cb5bcfce3d1c20f8d133862bd.zip
app-i18n/fcitx: Use slotted Lua.
Closes: https://bugs.gentoo.org/752549 Signed-off-by: Arfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org> Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'app-i18n/fcitx')
-rw-r--r--app-i18n/fcitx/fcitx-4.2.9.8.ebuild20
-rw-r--r--app-i18n/fcitx/fcitx-4.9999.ebuild20
2 files changed, 34 insertions, 6 deletions
diff --git a/app-i18n/fcitx/fcitx-4.2.9.8.ebuild b/app-i18n/fcitx/fcitx-4.2.9.8.ebuild
index d08d80a13212..b2c346af0251 100644
--- a/app-i18n/fcitx/fcitx-4.2.9.8.ebuild
+++ b/app-i18n/fcitx/fcitx-4.2.9.8.ebuild
@@ -2,8 +2,9 @@
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
+LUA_COMPAT=(lua{5-1,5-2,5-3,5-4})
-inherit cmake gnome2-utils xdg-utils
+inherit cmake gnome2-utils lua-single xdg-utils
if [[ "${PV}" =~ (^|\.)9999$ ]]; then
inherit git-r3
@@ -28,7 +29,9 @@ LICENSE="BSD-1 GPL-2+ LGPL-2+ MIT"
SLOT="4"
KEYWORDS="~amd64 ~arm64 ~hppa ~ppc ~ppc64 ~x86"
IUSE="+X +autostart +cairo debug +enchant gtk2 +gtk3 +introspection lua nls opencc +pango +table test +xkb"
-REQUIRED_USE="cairo? ( X ) pango? ( cairo )"
+REQUIRED_USE="cairo? ( X )
+ lua? ( ${LUA_REQUIRED_USE} )
+ pango? ( cairo )"
RESTRICT="!test? ( test )"
BDEPEND="dev-util/glib-utils
@@ -62,7 +65,7 @@ DEPEND="dev-libs/glib:2
enchant? ( app-text/enchant:= )
gtk2? ( x11-libs/gtk+:2 )
gtk3? ( x11-libs/gtk+:3 )
- lua? ( dev-lang/lua:0= )
+ lua? ( ${LUA_DEPS} )
nls? ( sys-devel/gettext )
opencc? ( app-i18n/opencc:0= )
xkb? (
@@ -78,6 +81,12 @@ PATCHES=(
DOCS=(AUTHORS ChangeLog THANKS)
+pkg_setup() {
+ if use lua; then
+ lua-single_pkg_setup
+ fi
+}
+
src_prepare() {
if [[ "${PV}" =~ (^|\.)9999$ ]]; then
ln -s "${DISTDIR}/fcitx-data-pinyin.tar.gz" src/im/pinyin/data/pinyin.tar.gz || die
@@ -114,6 +123,11 @@ src_configure() {
-DENABLE_XDGAUTOSTART=$(usex autostart ON OFF)
-DENABLE_XKB=$(usex xkb ON OFF)
)
+ if use lua; then
+ mycmakeargs+=(
+ -DLUA_MODULE_NAME=lua
+ )
+ fi
cmake_src_configure
}
diff --git a/app-i18n/fcitx/fcitx-4.9999.ebuild b/app-i18n/fcitx/fcitx-4.9999.ebuild
index 14ddb1d72205..0abf9932c60d 100644
--- a/app-i18n/fcitx/fcitx-4.9999.ebuild
+++ b/app-i18n/fcitx/fcitx-4.9999.ebuild
@@ -2,8 +2,9 @@
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
+LUA_COMPAT=(lua{5-1,5-2,5-3,5-4})
-inherit cmake gnome2-utils xdg-utils
+inherit cmake gnome2-utils lua-single xdg-utils
if [[ "${PV}" =~ (^|\.)9999$ ]]; then
inherit git-r3
@@ -28,7 +29,9 @@ LICENSE="BSD-1 GPL-2+ LGPL-2+ MIT"
SLOT="4"
KEYWORDS=""
IUSE="+X +autostart +cairo debug +enchant gtk2 +gtk3 +introspection lua nls opencc +pango +table test +xkb"
-REQUIRED_USE="cairo? ( X ) pango? ( cairo )"
+REQUIRED_USE="cairo? ( X )
+ lua? ( ${LUA_REQUIRED_USE} )
+ pango? ( cairo )"
RESTRICT="!test? ( test )"
BDEPEND="dev-util/glib-utils
@@ -62,7 +65,7 @@ DEPEND="dev-libs/glib:2
enchant? ( app-text/enchant:= )
gtk2? ( x11-libs/gtk+:2 )
gtk3? ( x11-libs/gtk+:3 )
- lua? ( dev-lang/lua:0= )
+ lua? ( ${LUA_DEPS} )
nls? ( sys-devel/gettext )
opencc? ( app-i18n/opencc:0= )
xkb? (
@@ -78,6 +81,12 @@ PATCHES=(
DOCS=(AUTHORS ChangeLog THANKS)
+pkg_setup() {
+ if use lua; then
+ lua-single_pkg_setup
+ fi
+}
+
src_prepare() {
if [[ "${PV}" =~ (^|\.)9999$ ]]; then
ln -s "${DISTDIR}/fcitx-data-pinyin.tar.gz" src/im/pinyin/data/pinyin.tar.gz || die
@@ -114,6 +123,11 @@ src_configure() {
-DENABLE_XDGAUTOSTART=$(usex autostart ON OFF)
-DENABLE_XKB=$(usex xkb ON OFF)
)
+ if use lua; then
+ mycmakeargs+=(
+ -DLUA_MODULE_NAME=lua
+ )
+ fi
cmake_src_configure
}