summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYongxiang Liang <tanekliang@gmail.com>2024-03-01 21:32:42 +0800
committerYixun Lan <dlan@gentoo.org>2024-03-08 09:06:32 +0000
commit451afd917a514603284af73106f1b808f845e31c (patch)
tree21c34e497241a10d8fd621ac3451d974ad1fcc9b /app-i18n
parentapp-i18n/libime: add 1.1.6 (diff)
downloadgentoo-451afd917a514603284af73106f1b808f845e31c.tar.gz
gentoo-451afd917a514603284af73106f1b808f845e31c.tar.bz2
gentoo-451afd917a514603284af73106f1b808f845e31c.zip
app-i18n/fcitx-chinese-addons: add 5.1.4
Signed-off-by: Yongxiang Liang <tanekliang@gmail.com> Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/fcitx-chinese-addons/Manifest1
-rw-r--r--app-i18n/fcitx-chinese-addons/fcitx-chinese-addons-5.1.4.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/app-i18n/fcitx-chinese-addons/Manifest b/app-i18n/fcitx-chinese-addons/Manifest
index 8305fe5c1146..b96ae14d6feb 100644
--- a/app-i18n/fcitx-chinese-addons/Manifest
+++ b/app-i18n/fcitx-chinese-addons/Manifest
@@ -1 +1,2 @@
DIST fcitx5-chinese-addons-5.1.3_dict.tar.xz 884664 BLAKE2B 6e9f931c146798bbbd76e7a55d62d50de2c8173d0dddcb48ea78259dac62fe41cb4be4421c6d6d81a5b094a3ebe258b1d20b42e2891451da55723e3978c1379a SHA512 4ea52ec45af70b552d8d4af3ed077662d6d839d3984bc41858b4710fe5b1dc169c63e223770f5400718c1c18aa745e77305f242409fa1cc523cee8475eb2e9ff
+DIST fcitx5-chinese-addons-5.1.4_dict.tar.xz 885456 BLAKE2B 239b2092d9b4ca77d7c0373a85e7a0e5b03e223c477b8704e36657349cf3ba006791e77a064826cd452eb6e5e81d33831feceabb9a51a8d26275f70deb04658a SHA512 99f3cc101532879c126e2699d338528a25531b782a5c1f1e93cd363437567c1ba7b0173aca56f887089d4379e86aecf7977139b5b5c44d54e0bd9a416b01e976
diff --git a/app-i18n/fcitx-chinese-addons/fcitx-chinese-addons-5.1.4.ebuild b/app-i18n/fcitx-chinese-addons/fcitx-chinese-addons-5.1.4.ebuild
new file mode 100644
index 000000000000..009b5efe7416
--- /dev/null
+++ b/app-i18n/fcitx-chinese-addons/fcitx-chinese-addons-5.1.4.ebuild
@@ -0,0 +1,63 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN="fcitx5-chinese-addons"
+
+inherit cmake xdg
+
+DESCRIPTION="Addons related to Chinese, including IME previous bundled inside fcitx4."
+HOMEPAGE="https://github.com/fcitx/fcitx5-chinese-addons"
+SRC_URI="https://download.fcitx-im.org/fcitx5/${MY_PN}/${MY_PN}-${PV}_dict.tar.xz"
+
+LICENSE="GPL-2+ LGPL-2+"
+KEYWORDS="~amd64 ~arm64 ~loong ~riscv ~x86"
+SLOT="5"
+IUSE="+data +gui webengine +cloudpinyin +qt5 qt6 lua +opencc test"
+REQUIRED_USE="
+ webengine? ( gui )
+"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=app-i18n/fcitx-5.1.6:5
+ >=app-i18n/libime-1.1.3:5[data?]
+ >=dev-libs/boost-1.61:=
+ cloudpinyin? ( net-misc/curl )
+ lua? ( app-i18n/fcitx-lua:5 )
+ opencc? ( app-i18n/opencc:= )
+ gui? (
+ qt5? (
+ dev-qt/qtconcurrent:5
+ app-i18n/fcitx-qt:5[qt5,-onlyplugin]
+ webengine? ( dev-qt/qtwebengine:5[widgets] )
+ )
+ qt6? (
+ dev-qt/qtbase:6[concurrent]
+ app-i18n/fcitx-qt:5[qt6,-onlyplugin]
+ webengine? ( dev-qt/qtwebengine:6[widgets] )
+ )
+ )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ kde-frameworks/extra-cmake-modules:0
+ virtual/pkgconfig
+"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_BROWSER=$(usex webengine)
+ -DENABLE_CLOUDPINYIN=$(usex cloudpinyin)
+ -DENABLE_DATA=$(usex data)
+ -DENABLE_GUI=$(usex gui)
+ -DENABLE_OPENCC=$(usex opencc)
+ -DENABLE_TEST=$(usex test)
+ -DUSE_WEBKIT=no
+ -DUSE_QT6=$(usex qt6)
+ )
+ cmake_src_configure
+}