summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-10-25 13:35:23 +0100
committerSam James <sam@gentoo.org>2022-10-25 13:47:47 +0100
commit99693f92524909539b83cffd9c2fdb4a21158150 (patch)
tree729727e4ae1baa3a7196e62a2013318156238fa1 /app-misc/cstream
parentsci-chemistry/chemex: drop 2021.4.0_p6-r1 (diff)
downloadgentoo-99693f92524909539b83cffd9c2fdb4a21158150.tar.gz
gentoo-99693f92524909539b83cffd9c2fdb4a21158150.tar.bz2
gentoo-99693f92524909539b83cffd9c2fdb4a21158150.zip
app-misc/cstream: fix build w/ Clang 16
Closes: https://bugs.gentoo.org/871225 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-misc/cstream')
-rw-r--r--app-misc/cstream/cstream-3.2.1-r1.ebuild (renamed from app-misc/cstream/cstream-3.2.1.ebuild)4
-rw-r--r--app-misc/cstream/files/cstream-3.2.1-Fix-implicit-function-declaration.patch25
2 files changed, 29 insertions, 0 deletions
diff --git a/app-misc/cstream/cstream-3.2.1.ebuild b/app-misc/cstream/cstream-3.2.1-r1.ebuild
index 315ee13ddc53..b02cc0a8efaa 100644
--- a/app-misc/cstream/cstream-3.2.1.ebuild
+++ b/app-misc/cstream/cstream-3.2.1-r1.ebuild
@@ -13,6 +13,10 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.2.1-Fix-implicit-function-declaration.patch
+)
+
src_prepare() {
default
diff --git a/app-misc/cstream/files/cstream-3.2.1-Fix-implicit-function-declaration.patch b/app-misc/cstream/files/cstream-3.2.1-Fix-implicit-function-declaration.patch
new file mode 100644
index 000000000000..0e158afdd39a
--- /dev/null
+++ b/app-misc/cstream/files/cstream-3.2.1-Fix-implicit-function-declaration.patch
@@ -0,0 +1,25 @@
+From aba21403014d3a0c4886b930ce3e7c07e2df5169 Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Tue, 25 Oct 2022 13:34:28 +0100
+Subject: [PATCH] Fix implicit function declaration
+
+Bug: https://bugs.gentoo.org/871225
+--- a/cstream.c
++++ b/cstream.c
+@@ -92,6 +92,8 @@
+
+ #ifndef NOSOUND
+
++#include <sys/ioctl.h>
++
+ #ifdef HAVE_MACHINE_SOUNDCARD_H
+ #include <machine/soundcard.h>
+ #define WANT_SOUND 1
+@@ -103,7 +105,6 @@
+ #ifdef HAVE_LINUX_SOUNDCARD_H
+ #include <linux/soundcard.h>
+ #define WANT_SOUND 1
+-#include <sys/ioctl.h>
+ #endif /* linux/soundcard.h */
+ #endif /* either soundcard.h */
+ #endif /* either soundcard.h */