summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-misc/wcd
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-misc/wcd')
-rw-r--r--app-misc/wcd/Manifest1
-rw-r--r--app-misc/wcd/files/wcd-5.2.5-gentoo.patch72
-rw-r--r--app-misc/wcd/metadata.xml8
-rw-r--r--app-misc/wcd/wcd-5.2.7.ebuild45
4 files changed, 126 insertions, 0 deletions
diff --git a/app-misc/wcd/Manifest b/app-misc/wcd/Manifest
new file mode 100644
index 000000000000..be0d9b6cf252
--- /dev/null
+++ b/app-misc/wcd/Manifest
@@ -0,0 +1 @@
+DIST wcd-5.2.7.tar.gz 622613 SHA256 e5f56824e054c6726186271b20a5de3c5b167116b97785a925907981cf3e3b39 SHA512 9f5b89d8160f685b729234cc8c03f16b795797dd6eaf2d9e1bbf1949b27ef971908b78642679d3bf1d99b128b390cd5dbd211e4ff03b0539dd287c578088e02e WHIRLPOOL 3354e380dceaed394e0eb9bac3f474edc819270a117baf5812a1e7252b2cef207862746af2b21dd71de837459bc6281a45a9099f5a6351def49e3c1ce780960d
diff --git a/app-misc/wcd/files/wcd-5.2.5-gentoo.patch b/app-misc/wcd/files/wcd-5.2.5-gentoo.patch
new file mode 100644
index 000000000000..c838e131aa5f
--- /dev/null
+++ b/app-misc/wcd/files/wcd-5.2.5-gentoo.patch
@@ -0,0 +1,72 @@
+ src/Makefile | 20 ++++++++++----------
+ 1 file changed, 10 insertions(+), 10 deletions(-)
+
+diff --git a/src/Makefile b/src/Makefile
+index d4120cc..4505b8d 100644
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -46,12 +46,12 @@ include version.mk
+
+ CC ?= gcc
+ STATIC =
+-STRIP = strip
++STRIP =
+
+ ENABLE_NLS = 1
+
+ PACKAGE = wcd
+-EXT = .exe
++EXT =
+ PROGRAM = $(PACKAGE)$(EXT)
+ BIN = $(PROGRAM)
+
+@@ -188,9 +188,9 @@ endif
+ # possible values: ncurses, curses, pdcurses, pdcursesw or <empty>
+
+ ifdef UCS
+- CURSES = ncursesw
++ CURSES = $(shell pkg-config --libs ncursesw)
+ else
+- CURSES = ncurses
++ CURSES = $(shell pkg-config --libs ncurses)
+ endif
+
+ ifdef CURSES
+@@ -201,7 +201,7 @@ endif
+
+ ifneq (,$(CURSES))
+ DEFS_CURSES = -DWCD_USECURSES
+- LIB_CURSES = -l$(CURSES)
++ LIB_CURSES = $(CURSES)
+ endif
+
+
+@@ -406,15 +406,15 @@ ifdef ASCII_TREE
+ endif
+
+ LDFLAGS_USER =
+-LDFLAGS = $(RPM_OPT_FLAGS) \
++LIBS = $(RPM_OPT_FLAGS) \
+ $(LDFLAGS_EXTRA) \
+ $(NLFLAG) \
+ $(LDFLAG_STATIC) \
+ $(LDFLAGS_USER)
+
+-LIBS = $(LIB_CURSES) \
+- $(LIB_UNISTRING) \
+- $(LIBS_EXTRA)
++LIBS += $(LIB_CURSES) \
++ $(LIB_UNISTRING) \
++ $(LIBS_EXTRA)
+
+ DEFS_USER =
+ DEFS = $(DEF_UNIX) $(DEFS_CURSES) $(EXTRA_DEFS) $(DEFS_USER)
+@@ -470,7 +470,7 @@ status:
+
+ $(BIN): $(OBJS1)
+ $(MAKE) status
+- $(CC) $(OBJS1) $(LDFLAGS) $(LIBS) -o $@
++ $(CC) $(LDFLAGS) $(OBJS1) -o $@ $(LIBS)
+
+ %.o: %.c
+ $(CC) $(CFLAGS) $(EXTRA_CFLAGS) $(DEFS) -c $< -o $@
diff --git a/app-misc/wcd/metadata.xml b/app-misc/wcd/metadata.xml
new file mode 100644
index 000000000000..25d6ffee85fd
--- /dev/null
+++ b/app-misc/wcd/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>shell-tools</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-misc/wcd/wcd-5.2.7.ebuild b/app-misc/wcd/wcd-5.2.7.ebuild
new file mode 100644
index 000000000000..d47e18cfe9c3
--- /dev/null
+++ b/app-misc/wcd/wcd-5.2.7.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Wherever Change Directory"
+HOMEPAGE="http://waterlan.home.xs4all.nl/#WCD_ANCHOR"
+SRC_URI="http://waterlan.home.xs4all.nl/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="amd64 arm x86 ~amd64-linux ~x86-linux"
+IUSE="nls unicode"
+
+CDEPEND="
+ sys-libs/ncurses[unicode?]
+ unicode? ( dev-libs/libunistring )"
+DEPEND="${CDEPEND}
+ app-text/ghostscript-gpl"
+RDEPEND="${CDEPEND}"
+
+S="${WORKDIR}"/${P}/src
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-5.2.5-gentoo.patch
+ tc-export CC
+}
+
+src_compile() {
+ local mycompile="LFS=1"
+ use nls || mycompile="${mycompile} ENABLE_NLS="
+ use unicode && mycompile="${mycompile} UCS=1 UNINORM=1"
+ emake \
+ ${mycompile}
+}
+
+src_install() {
+ local DOCS="../README.txt"
+ default
+ emake DESTDIR="${D}" DOTWCD=1 install-profile sysconfdir="/etc"
+}