summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-07-07 02:25:41 +0100
committerSam James <sam@gentoo.org>2024-07-07 02:52:20 +0100
commit08bcb02aaab2d358ec820f593260984c42ae30b6 (patch)
tree9db2c1f74fe3dfc5772bc4e37a6eaad28017a639 /app-shells
parentdev-python/pip: Keyword 24.1.1 alpha, #934778 (diff)
downloadgentoo-08bcb02aaab2d358ec820f593260984c42ae30b6.tar.gz
gentoo-08bcb02aaab2d358ec820f593260984c42ae30b6.tar.bz2
gentoo-08bcb02aaab2d358ec820f593260984c42ae30b6.zip
app-shells/bash: sync alpha+live
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/bash/bash-5.3_alpha_p20240628.ebuild12
-rw-r--r--app-shells/bash/bash-9999.ebuild12
2 files changed, 12 insertions, 12 deletions
diff --git a/app-shells/bash/bash-5.3_alpha_p20240628.ebuild b/app-shells/bash/bash-5.3_alpha_p20240628.ebuild
index 3dbf9e257f1b..f116d8c93a63 100644
--- a/app-shells/bash/bash-5.3_alpha_p20240628.ebuild
+++ b/app-shells/bash/bash-5.3_alpha_p20240628.ebuild
@@ -381,7 +381,7 @@ pkg_postinst() {
read -r old_ver <<<"${REPLACING_VERSIONS}"
if [[ ! $old_ver ]]; then
:
- elif ver_test "$old_ver" -ge "5.2" && ver_test "$old_ver" -ge "5.2_p26-r7"; then
+ elif ver_test "$old_ver" -ge "5.2" && ver_test "$old_ver" -ge "5.2_p26-r8"; then
return
fi
@@ -396,11 +396,11 @@ PROMPT_COMMAND variable are now advised to append their commands like so:
PROMPT_COMMAND+=('custom command goes here')
Gentoo no longer defaults to having bash set the window title in the case
-that the terminal is controlled by sshd(8), unless screen or tmux are in use
-or the terminal reliably supports saving and restoring the title (as
-alacritty and foot do). Those wanting to set the title unconditionally may
-adjust ~/.bashrc - or create a custom /etc/bash/bashrc.d drop-in - to set
-PROMPT_COMMMAND like so:
+that the terminal is controlled by sshd(8), unless screen is launched on the
+remote side or the terminal reliably supports saving and restoring the title
+(as alacritty, foot and tmux do). Those wanting for the title to be set
+regardless may adjust ~/.bashrc - or create a custom /etc/bash/bashrc.d
+drop-in - to set PROMPT_COMMMAND like so:
PROMPT_COMMAND=(genfun_set_win_title)
diff --git a/app-shells/bash/bash-9999.ebuild b/app-shells/bash/bash-9999.ebuild
index 3dbf9e257f1b..f116d8c93a63 100644
--- a/app-shells/bash/bash-9999.ebuild
+++ b/app-shells/bash/bash-9999.ebuild
@@ -381,7 +381,7 @@ pkg_postinst() {
read -r old_ver <<<"${REPLACING_VERSIONS}"
if [[ ! $old_ver ]]; then
:
- elif ver_test "$old_ver" -ge "5.2" && ver_test "$old_ver" -ge "5.2_p26-r7"; then
+ elif ver_test "$old_ver" -ge "5.2" && ver_test "$old_ver" -ge "5.2_p26-r8"; then
return
fi
@@ -396,11 +396,11 @@ PROMPT_COMMAND variable are now advised to append their commands like so:
PROMPT_COMMAND+=('custom command goes here')
Gentoo no longer defaults to having bash set the window title in the case
-that the terminal is controlled by sshd(8), unless screen or tmux are in use
-or the terminal reliably supports saving and restoring the title (as
-alacritty and foot do). Those wanting to set the title unconditionally may
-adjust ~/.bashrc - or create a custom /etc/bash/bashrc.d drop-in - to set
-PROMPT_COMMMAND like so:
+that the terminal is controlled by sshd(8), unless screen is launched on the
+remote side or the terminal reliably supports saving and restoring the title
+(as alacritty, foot and tmux do). Those wanting for the title to be set
+regardless may adjust ~/.bashrc - or create a custom /etc/bash/bashrc.d
+drop-in - to set PROMPT_COMMMAND like so:
PROMPT_COMMAND=(genfun_set_win_title)