summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-12-05 23:06:39 +0100
committerMaciej Barć <xgqt@gentoo.org>2024-12-06 01:42:57 +0100
commita5c557f10ad5df7d920223eb1c7132fd637242da (patch)
treebe29c84e3809eb1c46c1aa2a045f54ae3820dcf2 /app-shells
parentapp-shells/pwsh-bin: drop old 7.4.4 (diff)
downloadgentoo-a5c557f10ad5df7d920223eb1c7132fd637242da.tar.gz
gentoo-a5c557f10ad5df7d920223eb1c7132fd637242da.tar.bz2
gentoo-a5c557f10ad5df7d920223eb1c7132fd637242da.zip
app-shells/pwsh-bin: bump to 7.4.6
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/pwsh-bin/Manifest3
-rw-r--r--app-shells/pwsh-bin/pwsh-bin-7.4.6.ebuild71
2 files changed, 74 insertions, 0 deletions
diff --git a/app-shells/pwsh-bin/Manifest b/app-shells/pwsh-bin/Manifest
index d0ba6e8edd67..f490d5e29fdb 100644
--- a/app-shells/pwsh-bin/Manifest
+++ b/app-shells/pwsh-bin/Manifest
@@ -1,3 +1,6 @@
DIST powershell-7.4.5-linux-arm32.tar.gz 69183797 BLAKE2B 44ca41b55f6cebde7a2717cb04550ae675df019fc13872a6e1a8dea93ad4802663b21fb6caa19ffdd6335e6d908022881b2953019c9cfae05aee4ce3bbe666ce SHA512 3bd6f846d4a1ac0d67764792314031c61cc399386ef65253e6080f234bee07333acdcc88dca68b9fce75a5bfd71ea27d648176d39925866f304ca45a6d8dddb8
DIST powershell-7.4.5-linux-arm64.tar.gz 68157221 BLAKE2B 4665d26f22c74129888c59f06fceac17e61c38c83e3f3178e3bf2d566a6f67748451bd74b5ad717896c2f4f1ff5536c7f71a656cf11fabb7790aac152484ef5a SHA512 de7fcdfe132e1e50a71caf6aff62f0fd915b9eb361147c15d746f7cb0246d544ee66076118ea74589b26e0548ad32e1eed8f5b59fde9be7798df502f002934a8
DIST powershell-7.4.5-linux-x64.tar.gz 70898869 BLAKE2B c315c1ed361c7f97e834fbac589a0d4edc175d808e6b66d526fe2cdaf9e74ef2431a4cd513689fe79097c173cb988818f80a5f5101842e2ca96796b685fd618a SHA512 372959a6a5fa8a7ebe1c34999fa04d1ceb1eb30c6b8c082e030d09e5d4ed7782616002d5eb648412aed94d9998367358245544c685cbedfe60f9a522f9cda4f1
+DIST powershell-7.4.6-linux-arm32.tar.gz 69951436 BLAKE2B f14e3ac936bea8d79cb86dd92feec484afa87942c5d9a1a277c77d9bf23ab273053a4c6f903e9087ce4afd240cd2e2144033de18efd487733724cdf3767b877b SHA512 8f0c181c6194fe4a34d47fcef16af14ca69a647999746911a2f5d139186dc6d3f8faf87fdec307a895993364127aebc565b4ecb2fd098cf36aa2b09b3ce1227e
+DIST powershell-7.4.6-linux-arm64.tar.gz 68949931 BLAKE2B 1e8a3f3299c0ca80aa2fe32f26ef495807201903ef19efb959ebce595c62807b7c51ead5ca625d72f46333e6f13b70adecc210805d9c965992c8c71dd8f9b0c7 SHA512 61bef872ed9873f6f0af76ffe2a3eece404961d58b13fae8c886458db9f348424369761e308b24e6fa348ad4ed220168331743c528c0c04760933a950ab04afe
+DIST powershell-7.4.6-linux-x64.tar.gz 71645796 BLAKE2B 7bf99d83dabf5b599699395715bee094f1b414e4603022f962b2372f4f4f61c10c1afbf47b9dd86aadfa17e2a917ef4e6dfd5011a5fecb37b0dbf123f6dfc51d SHA512 0a449f458bafeeacb3c410d83ce2f89f117f001a4b4a18b57dd3282ac358f382a13019657343f66a5cbd9c23b93df346823ac5337393d1addc948d550d3bf89d
diff --git a/app-shells/pwsh-bin/pwsh-bin-7.4.6.ebuild b/app-shells/pwsh-bin/pwsh-bin-7.4.6.ebuild
new file mode 100644
index 000000000000..e09b2d5daf99
--- /dev/null
+++ b/app-shells/pwsh-bin/pwsh-bin-7.4.6.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit wrapper
+
+DESCRIPTION="Cross-platform automation and configuration tool (binary package)"
+HOMEPAGE="https://microsoft.com/powershell/
+ https://github.com/PowerShell/PowerShell/"
+
+BASE_URI="https://github.com/PowerShell/PowerShell/releases/download/"
+SRC_URI="
+ amd64? ( ${BASE_URI}/v${PV}/powershell-${PV}-linux-x64.tar.gz )
+ arm64? ( ${BASE_URI}/v${PV}/powershell-${PV}-linux-arm64.tar.gz )
+ arm? ( ${BASE_URI}/v${PV}/powershell-${PV}-linux-arm32.tar.gz )
+"
+S="${WORKDIR}"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~arm64"
+REQUIRED_USE="elibc_glibc"
+
+RDEPEND="
+ app-crypt/mit-krb5:0/0
+ dev-libs/icu
+ dev-util/lttng-ust:0/2.12
+ sys-libs/pam:0/0
+ sys-libs/zlib:0/1
+ || (
+ dev-libs/openssl-compat:1.0.0
+ =dev-libs/openssl-1.0*:0/0
+ )
+"
+IDEPEND="
+ app-eselect/eselect-pwsh
+"
+
+QA_PREBUILT="*"
+
+src_install() {
+ local -a broken_symlinks
+ broken_symlinks=( libcrypto.so.1.0.0 libssl.so.1.0.0 )
+
+ local symlink
+ for symlink in "${broken_symlinks[@]}" ; do
+ if [[ -L "${symlink}" ]] ; then
+ rm "${symlink}" || die "failed to remove ${symlink}"
+ fi
+ done
+
+ local dest="opt/${PN}-${SLOT}"
+ local dest_root="/${dest}"
+
+ insinto "${dest_root}"
+ doins -r .
+
+ fperms 0755 "${dest_root}/pwsh"
+
+ local gentoo_path='PSModulePath="${PSModulePath}:${EPREFIX}/usr/share/GentooPowerShell/Modules:"'
+ make_wrapper "${PN}-${SLOT}" "env ${gentoo_path} ${dest_root}/pwsh"
+}
+
+pkg_postinst() {
+ eselect pwsh update ifunset
+}
+
+pkg_postrm() {
+ eselect pwsh update ifunset
+}