summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfred Wingate <parona@protonmail.com>2024-09-03 16:25:20 +0300
committerJoonas Niilola <juippis@gentoo.org>2024-10-21 15:36:22 +0300
commit8b5f5e2902634fde6943bcabcb40813ed8672488 (patch)
treebc7ad3298e57f197a449821af498de45f73c94de /app-text/zathura-djvu
parentapp-text/zathura-cb: update live (diff)
downloadgentoo-8b5f5e2902634fde6943bcabcb40813ed8672488.tar.gz
gentoo-8b5f5e2902634fde6943bcabcb40813ed8672488.tar.bz2
gentoo-8b5f5e2902634fde6943bcabcb40813ed8672488.zip
app-text/zathura-djvu: add 0.2.10
Signed-off-by: Alfred Wingate <parona@protonmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-text/zathura-djvu')
-rw-r--r--app-text/zathura-djvu/Manifest1
-rw-r--r--app-text/zathura-djvu/zathura-djvu-0.2.10.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/app-text/zathura-djvu/Manifest b/app-text/zathura-djvu/Manifest
index f491cc889022..4e459a113152 100644
--- a/app-text/zathura-djvu/Manifest
+++ b/app-text/zathura-djvu/Manifest
@@ -1 +1,2 @@
+DIST zathura-djvu-0.2.10.tar.xz 9408 BLAKE2B f779eeeba40abe444960716b8c14c51c32a3830a3f779074ea773bd9ff0d71736433ed29862bdf137a34ebb934bb562aa14031c07dda5cf97ddf278e47feb750 SHA512 c743e60588e07fe18f7da8db1ae9ae997ffb50ef696258f1901523159ff4d29e5649b13d6e52f53cf79f19429083308390c0b4923081451bf5c4bfb9ac6e8903
DIST zathura-djvu-0.2.9.tar.xz 8976 BLAKE2B f0a798e9473ad2d09bdf171f4689231d73fa1e1bbaa0faa750feb82db2e2b029a86bf759e642f92c0ba438ee88b9178969e5d2aec4f30d9cb049bd3bcd69639e SHA512 3c2815e7f1cdfb9fc594dc6ad65359245f322e5fa27f018fb9431747e4d474734f5efd134aaeb9dabde09b01de603b1d1dc7aede883b1ef81266e067b0490726
diff --git a/app-text/zathura-djvu/zathura-djvu-0.2.10.ebuild b/app-text/zathura-djvu/zathura-djvu-0.2.10.ebuild
new file mode 100644
index 000000000000..1cc4a9881a29
--- /dev/null
+++ b/app-text/zathura-djvu/zathura-djvu-0.2.10.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson xdg
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.pwmt.org/pwmt/zathura-djvu.git"
+ EGIT_BRANCH="develop"
+else
+ KEYWORDS="~amd64 ~arm ~riscv ~x86"
+ SRC_URI="https://pwmt.org/projects/zathura-djvu/download/${P}.tar.xz"
+fi
+
+DESCRIPTION="DjVu plug-in for zathura"
+HOMEPAGE="https://pwmt.org/projects/zathura-djvu/"
+
+LICENSE="ZLIB"
+SLOT="0"
+
+# Tests currently only validating data files
+RESTRICT="test"
+
+RDEPEND="app-text/djvu
+ >=app-text/zathura-0.3.9
+ dev-libs/girara:=
+ dev-libs/glib:2
+ x11-libs/cairo"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"