summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTupone Alfredo <tupone@gentoo.org>2017-11-22 18:25:51 +0000
committerTupone Alfredo <tupone@gentoo.org>2017-11-22 18:26:14 +0000
commitc1a39ac6cb6fb394052e79e4e7c2170ce954668d (patch)
tree57142578590fb0cd28c2d489d2a3e8e4323a4ec4 /dev-ada/gps-bin/gps-bin-2016.ebuild
parentsys-devel/binutils-config: add avr/msp symlink handling (diff)
downloadgentoo-c1a39ac6cb6fb394052e79e4e7c2170ce954668d.tar.gz
gentoo-c1a39ac6cb6fb394052e79e4e7c2170ce954668d.tar.bz2
gentoo-c1a39ac6cb6fb394052e79e4e7c2170ce954668d.zip
dev-ada/gps-bin: use only (gnat)gcc-4.9.4
Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'dev-ada/gps-bin/gps-bin-2016.ebuild')
-rw-r--r--dev-ada/gps-bin/gps-bin-2016.ebuild23
1 files changed, 6 insertions, 17 deletions
diff --git a/dev-ada/gps-bin/gps-bin-2016.ebuild b/dev-ada/gps-bin/gps-bin-2016.ebuild
index 25fd9b696789..c8fcc1c78b71 100644
--- a/dev-ada/gps-bin/gps-bin-2016.ebuild
+++ b/dev-ada/gps-bin/gps-bin-2016.ebuild
@@ -17,10 +17,7 @@ IUSE=""
DEPEND=""
RDEPEND="${DEPEND}
- dev-ada/gnatcoll[iconv,postgresql,projects,readline,sqlite]
- dev-ada/gprbuild[shared]
- dev-db/sqlite
- dev-lang/gnat-gpl
+ dev-ada/gnatcoll[gnat_2016,iconv,postgresql,projects,readline,sqlite]
dev-libs/atk
dev-libs/glib
dev-libs/gobject-introspection
@@ -38,24 +35,16 @@ RDEPEND="${DEPEND}
S="${WORKDIR}"/${MY_P}
-pkg_setup() {
- GCC=${ADA:-$(tc-getCC)}
- GNATLS="${GCC/gcc/gnatls}"
- GNAT="${GCC/gcc/gnat}"
- GNATMAKE="${GCC/gcc/gnatmake}"
- if [[ -z "$(type ${GNATLS} 2>/dev/null)" ]] ; then
- eerror "You need a gcc compiler that provides the Ada Compiler:"
- eerror "1) use gcc-config to select the right compiler or"
- eerror "2) set ADA=gcc-4.9.4 in make.conf"
- die "ada compiler not available"
- fi
-}
-
src_compile() {
:
}
src_install() {
+ GCC_PV=4.9.4
+ GCC=gcc-${GCC_PV}
+ GNATLS=gnatls-${GCC_PV}
+ GNAT=gnatt-${GCC_PV}
+ GNATMAKE=gnatmake-${GCC_PV}
into /opt/${P}
dobin bin/gps_exe
dobin bin/gps_cli