summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-08-30 15:32:44 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-08-30 17:48:15 -0400
commit6af24133782dc5b5455cc0a419002d85c0cdb22b (patch)
tree9c9e966f5e1aa17650032daf5c55a00259a7b1f5 /dev-games
parentdev-util/cargo-tarpaulin: add 0.21.0 (diff)
downloadgentoo-6af24133782dc5b5455cc0a419002d85c0cdb22b.tar.gz
gentoo-6af24133782dc5b5455cc0a419002d85c0cdb22b.tar.bz2
gentoo-6af24133782dc5b5455cc0a419002d85c0cdb22b.zip
dev-games/godot: give postinst elog about migration to 4
Not super important given imagine devs would know this well, and need to launch as "godot4" so won't be a surprise. But still won't hurt for when this gets keyworded. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-games')
-rw-r--r--dev-games/godot/godot-4.0_alpha14.ebuild10
1 files changed, 10 insertions, 0 deletions
diff --git a/dev-games/godot/godot-4.0_alpha14.ebuild b/dev-games/godot/godot-4.0_alpha14.ebuild
index 9844ed38787e..2e22a6f9fe5a 100644
--- a/dev-games/godot/godot-4.0_alpha14.ebuild
+++ b/dev-games/godot/godot-4.0_alpha14.ebuild
@@ -244,3 +244,13 @@ src_install() {
newins misc/dist/shell/_godot.zsh-completion _${s}
dosym _${s} /usr/share/zsh/site-functions/_${s}-runner
}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ if [[ ! ${REPLACING_VERSIONS} ]] && has_version ${CATEGORY}/${PN}:3; then
+ elog
+ elog "Remember to make backups before opening any Godot <=3.x projects in Godot 4."
+ elog "Automated migration is only partial, and it would be difficult to revert."
+ fi
+}