summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/filemanip
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/filemanip')
-rw-r--r--dev-haskell/filemanip/Manifest2
-rw-r--r--dev-haskell/filemanip/filemanip-0.3.6.2.ebuild25
-rw-r--r--dev-haskell/filemanip/filemanip-0.3.6.3.ebuild27
-rw-r--r--dev-haskell/filemanip/metadata.xml13
4 files changed, 67 insertions, 0 deletions
diff --git a/dev-haskell/filemanip/Manifest b/dev-haskell/filemanip/Manifest
new file mode 100644
index 000000000000..aa19b5d2b33b
--- /dev/null
+++ b/dev-haskell/filemanip/Manifest
@@ -0,0 +1,2 @@
+DIST filemanip-0.3.6.2.tar.gz 10192 SHA256 3f93da5faa33d675b1a64a90a262c2decfd3d28924f0a4bfb7c691053309810e SHA512 e177a88b010ba467957841c4affe32f86638299781544a38f883b7ccf6a0d2dadaf5fbc27650cc0ef95ef6c2341526f3e7091e0a5fe0716879b1e055a32d3f9d WHIRLPOOL c034bcac9795d7a02d2b79e26313b12808b888a522174fbdb5649b49845ff0dea4fa983711065de1c0eab3ba0a3064d14ddcea1a0bf9e47dec22236dd8b72265
+DIST filemanip-0.3.6.3.tar.gz 10369 SHA256 8836da17baaaf02ca080c9990ece4e0b0c8d6a128f458f8b64fd07b225ca9846 SHA512 5cb6ad4e310c1ae3b038ccfa3154536db73145e4dea4a7be1ae0563ba44565494e378fa8e459f449feac2bcc140f1128b0b3ec915acd2300e73cf012ada85160 WHIRLPOOL 1b8cfd0d0bb1d75f2610a9016f1496a1aa959104b38003ce9d7037ddc8793def6c321bab42cafa3222137efa47d06be4f8610710723456a667aaaae31ad4b239
diff --git a/dev-haskell/filemanip/filemanip-0.3.6.2.ebuild b/dev-haskell/filemanip/filemanip-0.3.6.2.ebuild
new file mode 100644
index 000000000000..cc8c842bc68f
--- /dev/null
+++ b/dev-haskell/filemanip/filemanip-0.3.6.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Expressive file and directory manipulation for Haskell"
+HOMEPAGE="https://github.com/bos/filemanip"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/mtl:=[profile?]
+ dev-haskell/unix-compat:=[profile?]
+ >=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6"
diff --git a/dev-haskell/filemanip/filemanip-0.3.6.3.ebuild b/dev-haskell/filemanip/filemanip-0.3.6.3.ebuild
new file mode 100644
index 000000000000..f170398fc380
--- /dev/null
+++ b/dev-haskell/filemanip/filemanip-0.3.6.3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.3
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Expressive file and directory manipulation for Haskell"
+HOMEPAGE="https://github.com/bos/filemanip"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/mtl:=[profile?]
+ dev-haskell/unix-compat:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+"
diff --git a/dev-haskell/filemanip/metadata.xml b/dev-haskell/filemanip/metadata.xml
new file mode 100644
index 000000000000..933506f8e66c
--- /dev/null
+++ b/dev-haskell/filemanip/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ A Haskell library for working with files and directories.
+ Includes code for pattern matching, finding files,
+ modifying file contents, and more.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">bos/filemanip</remote-id>
+ </upstream>
+</pkgmetadata>