summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/bcpkix
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/bcpkix')
-rw-r--r--dev-java/bcpkix/Manifest2
-rw-r--r--dev-java/bcpkix/bcpkix-1.50.ebuild99
-rw-r--r--dev-java/bcpkix/bcpkix-1.52.ebuild101
-rw-r--r--dev-java/bcpkix/metadata.xml5
4 files changed, 207 insertions, 0 deletions
diff --git a/dev-java/bcpkix/Manifest b/dev-java/bcpkix/Manifest
new file mode 100644
index 000000000000..2350c07b18d2
--- /dev/null
+++ b/dev-java/bcpkix/Manifest
@@ -0,0 +1,2 @@
+DIST bcpkix-jdk15on-150.tar.gz 1149901 SHA256 0be5bb948ec481b3d1f30ee80ef593b298b3782697f9eeee5c74cf270689b520 SHA512 17c5a9aa8c04defab46987063f847ee5fdedfc42d51e29ecad5053e3df5895c2c01899edb9222c3dab3ecf204eac9744249163dc2c1572fa2becaaf0924d2eb3 WHIRLPOOL 07197f1271ffc965479badcfd6b75450e5b0744f93031dd3721406dcac04c3f360b0d537cde3efa0f44f9ac06b4427a60f00743bfacd8dc7cf0a3d70193d5b32
+DIST bcpkix-jdk15on-152.tar.gz 1214022 SHA256 518205ea86f215a79267b7a64ea7ce29261f4983be1d3c2f6b6aa533092ce400 SHA512 a30f08aa6ae646219012b6e4763e57bd9021358ddc7d5ea588deb808a5555f67cc212a7d8cdc2a552922f550989d88965ba204521dd5bd9b17cfdb9ed09c3b5f WHIRLPOOL e9f855dc2571643fafaaa2167ba9afb5c34691966d86e6e712a5411467d47bcdac5fa15f5a3f736eb05092c25190e42c2fb40bbbce42d7dadd6fdce63fc8451a
diff --git a/dev-java/bcpkix/bcpkix-1.50.ebuild b/dev-java/bcpkix/bcpkix-1.50.ebuild
new file mode 100644
index 000000000000..8a49e4edcb80
--- /dev/null
+++ b/dev-java/bcpkix/bcpkix-1.50.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc source test"
+
+inherit java-pkg-2 java-ant-2
+
+MY_P="${PN}-jdk15on-${PV/./}"
+
+DESCRIPTION="Java cryptography APIs"
+HOMEPAGE="http://www.bouncycastle.org/java.html"
+SRC_URI="http://www.bouncycastle.org/download/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos"
+
+# Tests are currently broken. Needs further investigation.
+#
+# - java.lang.RuntimeException: java.security.NoSuchProviderException:
+# JCE cannot authenticate the provider BC
+#
+# - error: package org.bouncycastle.util.test does not exist
+RESTRICT="test"
+
+COMMON_DEPEND="
+ >=dev-java/bcprov-${PV}:0[test?]"
+
+DEPEND=">=virtual/jdk-1.5
+ app-arch/unzip
+ test? ( dev-java/junit:0 )
+ ${COMMON_DEPEND}"
+
+RDEPEND=">=virtual/jre-1.5
+ ${COMMON_DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ default
+ cd "${S}"
+ unpack ./src.zip
+}
+
+java_prepare() {
+ mkdir "${S}"/classes
+
+ if use test ; then
+ java-pkg_jar-from --build-only junit
+ fi
+
+ java-pkg_jar-from bcprov
+}
+
+src_compile() {
+ find org -name "*.java" > "${T}"/src.list
+
+ local cp="bcprov.jar"
+ if use test ; then
+ cp="${cp}:junit.jar"
+ else
+ sed -i '/\/test\//d' "${T}"/src.list || die "Failed to remove test classes"
+ fi
+
+ ejavac -d "${S}"/classes -cp ${cp} "@${T}"/src.list
+
+ cd "${S}"/classes || die
+
+ jar -cf "${S}"/${PN}.jar * || die "Failed to create jar."
+}
+
+src_test() {
+ local cp="${PN}.jar:bcprov.jar:junit.jar"
+ local pkg="org.bouncycastle"
+
+ java -cp ${cp} ${pkg}.tsp.test.AllTests | tee tsp.tests
+ java -cp ${cp} ${pkg}.pkcs.test.AllTests | tee pkcs.tests
+ java -cp ${cp} ${pkg}.openssl.test.AllTests | tee openssl.tests
+ java -cp ${cp} ${pkg}.mozilla.test.AllTests | tee mozilla.tests
+ java -cp ${cp} ${pkg}.eac.test.AllTests | tee eac.tests
+ java -cp ${cp} ${pkg}.dvcs.test.AllTests | tee dvcs.tests
+ java -cp ${cp} ${pkg}.cms.test.AllTests | tee cms.tests
+ java -cp ${cp} ${pkg}.cert.test.AllTests | tee cert.tests
+ java -cp ${cp} ${pkg}.cert.ocsp.test.AllTests | tee cert.ocsp.tests
+ java -cp ${cp} ${pkg}.cert.crmf.test.AllTests | tee cert.crmf.tests
+ java -cp ${cp} ${pkg}.cert.cmp.test.AllTests | tee cert.cmp.tests
+
+ grep -q FAILURES *.tests && die "Tests failed."
+}
+
+src_install() {
+ java-pkg_dojar "${S}"/${PN}.jar
+
+ use source && java-pkg_dosrc org
+ use doc && java-pkg_dojavadoc docs
+}
diff --git a/dev-java/bcpkix/bcpkix-1.52.ebuild b/dev-java/bcpkix/bcpkix-1.52.ebuild
new file mode 100644
index 000000000000..29e07b8c8749
--- /dev/null
+++ b/dev-java/bcpkix/bcpkix-1.52.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc source test"
+
+inherit java-pkg-2 java-ant-2
+
+MY_P="${PN}-jdk15on-${PV/./}"
+
+DESCRIPTION="Java cryptography APIs"
+HOMEPAGE="http://www.bouncycastle.org/java.html"
+SRC_URI="http://www.bouncycastle.org/download/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos"
+
+# Tests are currently broken. Needs further investigation.
+#
+# - java.lang.RuntimeException: java.security.NoSuchProviderException:
+# JCE cannot authenticate the provider BC
+#
+# - error: package org.bouncycastle.util.test does not exist
+RESTRICT="test"
+
+CDEPEND="
+ >=dev-java/bcprov-${PV}:0[test?]"
+
+DEPEND=">=virtual/jdk-1.6
+ app-arch/unzip
+ test? (
+ dev-java/junit:0
+ )
+ ${CDEPEND}"
+
+RDEPEND=">=virtual/jre-1.6
+ ${CDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ default
+ cd "${S}"
+ unpack ./src.zip
+}
+
+java_prepare() {
+ mkdir "${S}"/classes
+
+ if use test ; then
+ java-pkg_jar-from --build-only junit
+ fi
+
+ java-pkg_jar-from bcprov
+}
+
+src_compile() {
+ find org -name "*.java" > "${T}"/src.list
+
+ local cp="bcprov.jar"
+ if use test ; then
+ cp="${cp}:junit.jar"
+ else
+ sed -i '/\/test\//d' "${T}"/src.list || die "Failed to remove test classes"
+ fi
+
+ ejavac -d "${S}"/classes -cp ${cp} "@${T}"/src.list
+
+ cd "${S}"/classes || die
+
+ jar -cf "${S}"/${PN}.jar * || die "Failed to create jar."
+}
+
+src_test() {
+ local cp="${PN}.jar:bcprov.jar:junit.jar"
+ local pkg="org.bouncycastle"
+
+ java -cp ${cp} ${pkg}.tsp.test.AllTests | tee tsp.tests
+ java -cp ${cp} ${pkg}.pkcs.test.AllTests | tee pkcs.tests
+ java -cp ${cp} ${pkg}.openssl.test.AllTests | tee openssl.tests
+ java -cp ${cp} ${pkg}.mozilla.test.AllTests | tee mozilla.tests
+ java -cp ${cp} ${pkg}.eac.test.AllTests | tee eac.tests
+ java -cp ${cp} ${pkg}.dvcs.test.AllTests | tee dvcs.tests
+ java -cp ${cp} ${pkg}.cms.test.AllTests | tee cms.tests
+ java -cp ${cp} ${pkg}.cert.test.AllTests | tee cert.tests
+ java -cp ${cp} ${pkg}.cert.ocsp.test.AllTests | tee cert.ocsp.tests
+ java -cp ${cp} ${pkg}.cert.crmf.test.AllTests | tee cert.crmf.tests
+ java -cp ${cp} ${pkg}.cert.cmp.test.AllTests | tee cert.cmp.tests
+
+ grep -q FAILURES *.tests && die "Tests failed."
+}
+
+src_install() {
+ java-pkg_dojar "${S}"/${PN}.jar
+
+ use source && java-pkg_dosrc org
+ use doc && java-pkg_dojavadoc docs
+}
diff --git a/dev-java/bcpkix/metadata.xml b/dev-java/bcpkix/metadata.xml
new file mode 100644
index 000000000000..7303cef96964
--- /dev/null
+++ b/dev-java/bcpkix/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+</pkgmetadata>