summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/commons-codec
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/commons-codec')
-rw-r--r--dev-java/commons-codec/Manifest1
-rw-r--r--dev-java/commons-codec/commons-codec-1.7.ebuild42
-rw-r--r--dev-java/commons-codec/metadata.xml27
3 files changed, 70 insertions, 0 deletions
diff --git a/dev-java/commons-codec/Manifest b/dev-java/commons-codec/Manifest
new file mode 100644
index 000000000000..f1653aed1859
--- /dev/null
+++ b/dev-java/commons-codec/Manifest
@@ -0,0 +1 @@
+DIST commons-codec-1.7-src.tar.gz 291251 SHA256 816b5a9ae9ee67b918cb1864d0a24fbbc24ab1875992b6fc46ada6d62435e38a SHA512 31358283ac2827cb05486b8ff1512242153f61deb086f7fe145ee3ca38d96e43fba080a1e89a3b8cd44d09761015ff4dbe5226d29b7f9fcd59e68ca7701b28d6 WHIRLPOOL edc4caaf6ef56fd9c1a7437dacf873be53802eccbcb1f6035163946c07e3f4373e0698f069f00a8ad2bb5562a2c6a1ab909eccfccd6a527ce51dcedd2bd2bbfc
diff --git a/dev-java/commons-codec/commons-codec-1.7.ebuild b/dev-java/commons-codec/commons-codec-1.7.ebuild
new file mode 100644
index 000000000000..312298663560
--- /dev/null
+++ b/dev-java/commons-codec/commons-codec-1.7.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Implementations of common encoders and decoders in Java"
+HOMEPAGE="http://commons.apache.org/codec"
+SRC_URI="mirror://apache/commons/codec/source/${P}-src.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-macos"
+IUSE="test"
+
+RDEPEND=">=virtual/jre-1.6"
+DEPEND=">=virtual/jdk-1.6
+ test? (
+ dev-java/ant-junit:0
+ dev-java/junit:4
+ )"
+
+S=${WORKDIR}/${P}-src
+
+JAVA_ANT_ENCODING="ISO-8859-1"
+EANT_TEST_GENTOO_CLASSPATH="junit-4"
+JAVA_ANT_REWRITE_CLASSPATH="yes"
+
+src_test() {
+ java-pkg-2_src_test
+}
+
+src_install() {
+ java-pkg_newjar dist/${P}*.jar
+
+ dodoc RELEASE-NOTES.txt
+ use doc && java-pkg_dojavadoc dist/docs/api
+ use source && java-pkg_dosrc src/main/java/*
+}
diff --git a/dev-java/commons-codec/metadata.xml b/dev-java/commons-codec/metadata.xml
new file mode 100644
index 000000000000..4ddd96d6ead4
--- /dev/null
+++ b/dev-java/commons-codec/metadata.xml
@@ -0,0 +1,27 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+<herd>java</herd>
+
+<longdescription>
+Codec was formed as an attempt to focus development effort on one
+definitive implementation of the Base64 encoder. At the time of Codec's
+proposal, there were approximately 34 different Java classes that dealt
+with Base64 encoding spread over the Foundation's CVS repository.
+Developers in the Jakarta Tomcat project had implemented an original
+version of the Base64 codec which had been copied by the Commons
+HttpClient and Apache XML project's XML-RPC subproject. After almost one
+year, the two forked versions of Base64 had significantly diverged from
+one another. XML-RPC had applied numerous fixes and patches which were
+not applied to the Commons HttpClient Base64. Different subprojects had
+differing implementations at various levels of compliance with the RFC
+2045.
+
+Out of that confusing duplication of effort sprang this simple attempt
+to encourage code reuse among various projects. While this package
+contains a abstract framework for the creation of encoders and decoders,
+Codec itself is primarily focused on providing functional utilities for
+working with common encodings.
+</longdescription>
+</pkgmetadata>