summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolkmar W. Pogatzki <gentoo@pogatzki.net>2021-07-22 10:55:01 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2021-07-23 07:31:17 +0200
commit69003e1af15bd227162ef3b0a9371fddc0bfa4b2 (patch)
tree9e2253a73c9f228c8e94fb89ca40da5e67183993 /dev-java/commons-vfs
parentdev-java/commons-vfs: EAPI 7, min java 1.8:* (diff)
downloadgentoo-69003e1af15bd227162ef3b0a9371fddc0bfa4b2.tar.gz
gentoo-69003e1af15bd227162ef3b0a9371fddc0bfa4b2.tar.bz2
gentoo-69003e1af15bd227162ef3b0a9371fddc0bfa4b2.zip
dev-java/commons-vfs: remove obsolete version
Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net> Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'dev-java/commons-vfs')
-rw-r--r--dev-java/commons-vfs/commons-vfs-2.0-r1.ebuild69
1 files changed, 0 insertions, 69 deletions
diff --git a/dev-java/commons-vfs/commons-vfs-2.0-r1.ebuild b/dev-java/commons-vfs/commons-vfs-2.0-r1.ebuild
deleted file mode 100644
index e8991f3641cf..000000000000
--- a/dev-java/commons-vfs/commons-vfs-2.0-r1.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-JAVA_PKG_IUSE="doc source"
-
-inherit java-pkg-2 java-ant-2
-
-DESCRIPTION="A single API for accessing various different file systems"
-HOMEPAGE="http://commons.apache.org/vfs/"
-SRC_URI="mirror://apache/commons/vfs/source/${P}-src.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="2"
-KEYWORDS="~amd64 ~ppc64 ~x86 ~amd64-linux ~x86-linux"
-
-CDEPEND="
- dev-java/ant-core:0
- dev-java/commons-collections:0
- dev-java/commons-logging:0
- dev-java/commons-net:0
- dev-java/commons-httpclient:3
- dev-java/jackrabbit-webdav:0
- dev-java/jsch:0
- "
-
-RDEPEND=">=virtual/jre-1.6
- ${CDEPEND}"
-
-DEPEND=">=virtual/jdk-1.6
- ${CDEPEND}"
-
-S="${WORKDIR}/${P}/core"
-
-java_prepare() {
- epatch "${FILESDIR}"/${P}-incompatibility.patch
-
- cp "${FILESDIR}"/${P}-build.xml build.xml || die
-
- java-ant_rewrite-classpath
- java-ant_ignore-system-classes
-}
-
-EANT_GENTOO_CLASSPATH="
- ant-core
- commons-collections
- commons-logging
- commons-net
- commons-httpclient-3
- jackrabbit-webdav
- jsch
-"
-EANT_EXTRA_ARGS="-Dlibdir=${T}"
-
-# The build.xml is generated from maven and can't run the tests properly
-# Use maven test to execute these manually but that means downloading deps from
-# the internet. Also the tests need to login to some ftp servers and samba
-# shares so I doubt they work for everyone.
-#src_test() {
-# ANT_TASKS="ant-junit" eant test
-#}
-
-src_install() {
- java-pkg_newjar target/*.jar
-
- use doc && java-pkg_dojavadoc target/site/apidocs
- use source && java-pkg_dosrc src/main/java
-}