summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Byrne <salah.coronya@gmail.com>2022-03-08 17:06:12 -0600
committerIonen Wolkens <ionen@gentoo.org>2022-03-10 19:03:05 -0500
commitd4219669bd696fa7ab9efa3378e65ec4d6afeedf (patch)
tree4414ab10bb38cc26019684343cf02394dc6ff200 /dev-libs/libtpms
parentapp-misc/rpick: Drop 0.8.6 (diff)
downloadgentoo-d4219669bd696fa7ab9efa3378e65ec4d6afeedf.tar.gz
gentoo-d4219669bd696fa7ab9efa3378e65ec4d6afeedf.tar.bz2
gentoo-d4219669bd696fa7ab9efa3378e65ec4d6afeedf.zip
dev-libs/libtpms: Bump to 0.9.3
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Christopher Byrne <salah.coronya@gmail.com> Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-libs/libtpms')
-rw-r--r--dev-libs/libtpms/Manifest1
-rw-r--r--dev-libs/libtpms/libtpms-0.9.3.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-libs/libtpms/Manifest b/dev-libs/libtpms/Manifest
index 04de1f7e43a9..9be59aa15f5f 100644
--- a/dev-libs/libtpms/Manifest
+++ b/dev-libs/libtpms/Manifest
@@ -1 +1,2 @@
DIST libtpms-0.9.1.tar.gz 1261528 BLAKE2B 8a81fbea7dff44fe55da048f5121511c22ce264aaa64778ec28b6e55be64677f46f8266bed9edaeb57605ccede755ddfa7463a10e8fc806a86ea09d7a1f9283e SHA512 15ae14bca4ac24391ba06accae37d7e914e410ac9dc1aeae0743295371c9a0e0851f191c55bffb765cb731e8d397188be6441d2b6c1f5011b56a354428c4dad1
+DIST libtpms-0.9.3.tar.gz 1263192 BLAKE2B a58cc2f76775f0a0a266cf6da898d6c8e310998c201dc47a802d67fc07dbe1632a68e81b78da68a6350e1d64727c7b47154479b4d9bc19a55324a2d881cad94f SHA512 8616c712f958c28a415b0a97a3a24f439f757682c4b60642584eb13e4ab2d7895838e8e6e57936ff583259506f9b379ec47c76d5780c1b257f25513a5911c3cb
diff --git a/dev-libs/libtpms/libtpms-0.9.3.ebuild b/dev-libs/libtpms/libtpms-0.9.3.ebuild
new file mode 100644
index 000000000000..fc15af9bf0f4
--- /dev/null
+++ b/dev-libs/libtpms/libtpms-0.9.3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Library providing software emultion of a TPM"
+HOMEPAGE="https://github.com/stefanberger/libtpms"
+SRC_URI="https://github.com/stefanberger/libtpms/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+
+DEPEND="dev-libs/openssl:="
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.9.0-Remove-WError.patch"
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --with-openssl
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ if [[ ${REPLACING_VERSIONS} ]] && ver_test ${REPLACING_VERSIONS} -lt 0.8.0; then
+ elog "Versions of libtpms prior to 0.8.0 generate weaker than expected TPM 2.0 RSA"
+ elog "keys due to a flawed key creation algorithm. Because fixing this would render"
+ elog "existing sealed data inaccessible, to use the corrected algorithm, the old"
+ elog "TPM state file must be deleted and a new TPM state file created. Data still"
+ elog "sealed using the old state file will be permanently inaccessible. For the"
+ elog "details see https://github.com/stefanberger/libtpms/issues/183"
+ fi
+}