summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2024-07-15 12:12:03 +0200
committerAlfredo Tupone <tupone@gentoo.org>2024-07-15 12:12:03 +0200
commit2c2845c536a40b24546677bf22f17de96ce2bace (patch)
tree7c40b6bcce006ffa403e4aab597b317b46c11d42 /dev-ml/opam-repository/opam-repository-2.1.5.ebuild
parentdev-ml/opam-installer: add 2.1.5 (diff)
downloadgentoo-2c2845c536a40b24546677bf22f17de96ce2bace.tar.gz
gentoo-2c2845c536a40b24546677bf22f17de96ce2bace.tar.bz2
gentoo-2c2845c536a40b24546677bf22f17de96ce2bace.zip
dev-ml/opam-repository: add 2.1.5
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml/opam-repository/opam-repository-2.1.5.ebuild')
-rw-r--r--dev-ml/opam-repository/opam-repository-2.1.5.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-ml/opam-repository/opam-repository-2.1.5.ebuild b/dev-ml/opam-repository/opam-repository-2.1.5.ebuild
new file mode 100644
index 000000000000..ac92c2b7ab83
--- /dev/null
+++ b/dev-ml/opam-repository/opam-repository-2.1.5.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="opam repository libraries"
+HOMEPAGE="https://opam.ocaml.org/ https://github.com/ocaml/opam"
+SRC_URI="https://github.com/ocaml/opam/archive/${PV/_/-}.tar.gz -> opam-${PV}.tar.gz"
+S="${WORKDIR}/opam-${PV/_/-}"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+ocamlopt"
+RESTRICT="test"
+
+RDEPEND="
+ ~dev-ml/opam-format-${PV}:=[ocamlopt?]
+ dev-ml/re:=[ocamlopt?]
+ dev-ml/dose3:=[ocamlopt?]
+ dev-ml/opam-file-format:=[ocamlopt?]
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ cat <<- EOF >> "${S}/dune"
+ (env
+ (dev
+ (flags (:standard -warn-error -3-9-33)))
+ (release
+ (flags (:standard -warn-error -3-9-33))))
+ EOF
+}
+
+src_compile() {
+ dune-compile ${PN}
+}