summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTupone Alfredo <tupone@gentoo.org>2020-03-27 13:50:36 +0100
committerTupone Alfredo <tupone@gentoo.org>2020-03-27 13:50:36 +0100
commit73876a2b12f1954194ffe5809b8ef7b006d9c007 (patch)
treed0f3b22132dce769ec4f1090c2ebb68ce3c2b7ee /dev-ml/zarith/zarith-1.6.ebuild
parentapp-emulation/virtualbox: Removed old (diff)
downloadgentoo-73876a2b12f1954194ffe5809b8ef7b006d9c007.tar.gz
gentoo-73876a2b12f1954194ffe5809b8ef7b006d9c007.tar.bz2
gentoo-73876a2b12f1954194ffe5809b8ef7b006d9c007.zip
dev-ml/zarith: remove old versions
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml/zarith/zarith-1.6.ebuild')
-rw-r--r--dev-ml/zarith/zarith-1.6.ebuild52
1 files changed, 0 insertions, 52 deletions
diff --git a/dev-ml/zarith/zarith-1.6.ebuild b/dev-ml/zarith/zarith-1.6.ebuild
deleted file mode 100644
index 1e752ec0c1fe..000000000000
--- a/dev-ml/zarith/zarith-1.6.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit findlib eutils toolchain-funcs
-
-DESCRIPTION="Arithmetic and logic operations over arbitrary-precision integers"
-HOMEPAGE="https://github.com/ocaml/Zarith"
-SRC_URI="https://github.com/ocaml/Zarith/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="LGPL-2.1-with-linking-exception"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="doc mpir +ocamlopt"
-
-RDEPEND="
- >=dev-lang/ocaml-4.05:=[ocamlopt?]
- !mpir? ( dev-libs/gmp:0= )
- mpir? ( sci-libs/mpir )"
-
-DEPEND="${RDEPEND} dev-lang/perl"
-
-S="${WORKDIR}/Zarith-release-${PV}"
-
-src_configure() {
- tc-export CC
- ./configure -host "${CHOST}" \
- -ocamllibdir "/usr/$(get_libdir)" \
- -installdir "${ED}/usr/$(get_libdir)/ocaml" \
- $(usex mpir "-mpir" "-gmp") || die
-}
-
-src_compile() {
- emake HASOCAMLOPT=$(usex ocamlopt yes no) HASDYNLINK=$(usex ocamlopt yes no) all
- use doc && emake doc
-}
-
-src_test() {
- if use ocamlopt ; then
- emake HASOCAMLOPT=$(usex ocamlopt yes no) HASDYNLINK=$(usex ocamlopt yes no) tests
- else
- ewarn "Tests require USE=ocamlopt. Skipping them."
- fi
-}
-
-src_install() {
- findlib_src_preinst
- emake HASOCAMLOPT=$(usex ocamlopt yes no) HASDYNLINK=$(usex ocamlopt yes no) install
- dodoc Changes README.md
- use doc && dohtml html/*
-}