summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-10-26 13:19:36 +0100
committerAlexis Ballier <aballier@gentoo.org>2015-10-26 13:21:32 +0100
commitb761d019fbcc4ec2df5af9b192a18bc48173e67b (patch)
tree500bfe803d3ba99b4f95bf20e80f0371d4ff321b /dev-ml
parentsys-kernel/gentoo-sources: Auto stabilize 4.0.9 as per policy. Bug #564166 (diff)
downloadgentoo-b761d019fbcc4ec2df5af9b192a18bc48173e67b.tar.gz
gentoo-b761d019fbcc4ec2df5af9b192a18bc48173e67b.tar.bz2
gentoo-b761d019fbcc4ec2df5af9b192a18bc48173e67b.zip
dev-ml/findlib: Bump to 1.5.6.
Also add comment in patch to describe it. Package-Manager: portage-2.2.23
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/findlib/Manifest1
-rw-r--r--dev-ml/findlib/files/externalmeta.patch3
-rw-r--r--dev-ml/findlib/findlib-1.5.6.ebuild75
3 files changed, 79 insertions, 0 deletions
diff --git a/dev-ml/findlib/Manifest b/dev-ml/findlib/Manifest
index d393c5488520..c3a93c670a77 100644
--- a/dev-ml/findlib/Manifest
+++ b/dev-ml/findlib/Manifest
@@ -1,2 +1,3 @@
DIST findlib-1.4.tar.gz 231526 SHA256 6e4065e5d79d31176ec213ff94599c4eae17c3904c2896e845d0379a99f1bdf8 SHA512 7ee5bee74f6fc14c8d85496e673d42b63e056d35a724fe4f78fd1010a5af4506a9a962c0403fd96d5bf51f2278bfbe98a60aad65a171803cbde935cc3889157b WHIRLPOOL 31f1d0b9f1605a9a536ae996fb4abe5e1d5c47012759cb7bb45185d58a81e827d80285628b113f79d51b8b260cdff181c3eb05596adeea9a87070994058fce17
DIST findlib-1.5.5.tar.gz 240247 SHA256 aafaba4f7453c38347ff5269c6fd4f4c243ae2bceeeb5e10b9dab89329905946 SHA512 051817ae897a53b705ad641ae7e9010474f2320d3cc7cfd15edc9345f50566932cb44bf6f45772260706b5f9e9e91194802600c770c9c96f772985678db7209d WHIRLPOOL f1ad9b77c1f38f6d733f2a17c14649d4ca9f05215b5fa8124e71dc3e05b229c34af10415471d56964384c1fe0b0b0db453638d7e1238af916e5ff854b931cd76
+DIST findlib-1.5.6.tar.gz 250865 SHA256 7743b3dcaf8a344c882e89f61601f7f086d46c0f2ea4fcc3e54069236825e3f8 SHA512 18d23861a25b1508cb419af4cdd6e3cd83d51bef259f162c86b91460cf3dad75d6c2fc11173f60fe36b61ce3f81b78e69344f093adb9a82c36256d95180e93d8 WHIRLPOOL eb374e60c3f2fcc6172ec08803fbc5b0e83ea0d38644b4c13cb3d27b3dc13c7240a4f49a9ee51f9465ac6ff6075140c3e98b3eb0ea48690f260f139f37dfb63c
diff --git a/dev-ml/findlib/files/externalmeta.patch b/dev-ml/findlib/files/externalmeta.patch
index e391bf0fb1ec..6699692f231c 100644
--- a/dev-ml/findlib/files/externalmeta.patch
+++ b/dev-ml/findlib/files/externalmeta.patch
@@ -1,3 +1,6 @@
+Avoid installing META files for labltk and camlp4: Those are provided by their
+respective packages now.
+
Index: findlib-1.5.5/configure
===================================================================
--- findlib-1.5.5.orig/configure
diff --git a/dev-ml/findlib/findlib-1.5.6.ebuild b/dev-ml/findlib/findlib-1.5.6.ebuild
new file mode 100644
index 000000000000..1312843bbe44
--- /dev/null
+++ b/dev-ml/findlib/findlib-1.5.6.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit multilib eutils
+
+DESCRIPTION="OCaml tool to find/use non-standard packages"
+HOMEPAGE="http://projects.camlcity.org/projects/findlib.html"
+SRC_URI="http://download.camlcity.org/download/${P}.tar.gz"
+IUSE="doc +ocamlopt tk"
+
+LICENSE="MIT"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos"
+
+DEPEND=">=dev-lang/ocaml-4.02.1:=[ocamlopt?]
+ tk? ( dev-ml/labltk:= )"
+RDEPEND="${DEPEND}"
+
+ocamlfind_destdir="${EPREFIX}/usr/$(get_libdir)/ocaml"
+stublibs="${ocamlfind_destdir}/stublibs"
+
+src_prepare() {
+ epatch "${FILESDIR}/externalmeta.patch"
+}
+
+src_configure() {
+ local myconf
+ use tk && myconf="-with-toolbox"
+ ./configure -bindir "${EPREFIX}"/usr/bin -mandir "${EPREFIX}"/usr/share/man \
+ -sitelib ${ocamlfind_destdir} \
+ -config ${ocamlfind_destdir}/findlib/findlib.conf \
+ -no-custom \
+ ${myconf} || die "configure failed"
+}
+
+src_compile() {
+ emake -j1 all
+ if use ocamlopt; then
+ emake -j1 opt # optimized code
+ fi
+}
+
+src_install() {
+ emake prefix="${D}" install
+
+ dodir "${stublibs#${EPREFIX}}"
+
+ cd "${S}/doc"
+ dodoc QUICKSTART README DOCINFO
+ use doc && dohtml -r ref-html guide-html
+}
+
+check_stublibs() {
+ local ocaml_stdlib=`ocamlc -where`
+ local ldconf="${ocaml_stdlib}/ld.conf"
+
+ if [ ! -e ${ldconf} ]
+ then
+ echo "${ocaml_stdlib}" > ${ldconf}
+ echo "${ocaml_stdlib}/stublibs" >> ${ldconf}
+ fi
+
+ if [ -z `grep -e ${stublibs} ${ldconf}` ]
+ then
+ echo ${stublibs} >> ${ldconf}
+ fi
+}
+
+pkg_postinst() {
+ check_stublibs
+}