summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/GD/GD-2.460.0-r1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/GD/GD-2.460.0-r1.ebuild')
-rw-r--r--dev-perl/GD/GD-2.460.0-r1.ebuild73
1 files changed, 73 insertions, 0 deletions
diff --git a/dev-perl/GD/GD-2.460.0-r1.ebuild b/dev-perl/GD/GD-2.460.0-r1.ebuild
new file mode 100644
index 000000000000..fb99532a7a92
--- /dev/null
+++ b/dev-perl/GD/GD-2.460.0-r1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=LDS
+MODULE_VERSION=2.46
+inherit perl-module
+
+DESCRIPTION="interface to Thomas Boutell's gd library"
+
+LICENSE="|| ( Artistic-2 GPL-1 GPL-2 GPL-3 )" # Artistic-2 or GPL1+
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="animgif gif jpeg png truetype xpm"
+
+RDEPEND=">=media-libs/gd-2.0.33
+ png? (
+ media-libs/gd[png]
+ media-libs/libpng
+ sys-libs/zlib
+ )
+ jpeg? (
+ media-libs/gd[jpeg]
+ virtual/jpeg
+ )
+ truetype? (
+ media-libs/gd[truetype]
+ media-libs/freetype:2
+ )
+ xpm? (
+ media-libs/gd[xpm]
+ x11-libs/libXpm
+ )
+ gif? ( media-libs/giflib )"
+DEPEND="${RDEPEND}"
+
+SRC_TEST=do
+
+src_prepare(){
+ perl-module_src_prepare
+ sed -i "s/use Getopt::Long;/use Getopt::Long qw(:config pass_through);/" \
+ "${S}"/Makefile.PL || die
+}
+
+src_configure() {
+ local myconf
+ use gif && use animgif && myconf+=",ANIMGIF"
+ use jpeg && myconf+=",JPEG"
+ use truetype && myconf+=",FREETYPE"
+ use png && myconf+=",PNG"
+ use xpm && myconf+=",XPM"
+ use gif && myconf+=",GIF"
+ myconf="-options '${myconf:1}'"
+ perl-module_src_configure
+}
+
+src_test() {
+ if use png || use jpeg || use gif ; then
+ if has_version ">=media-libs/jpeg-7" || \
+ has_version "media-libs/libjpeg-turbo" ; then
+ # https://rt.cpan.org/Public/Bug/Display.html?id=49053
+ ewarn "Tests fail with >=media-libs/jpeg-7 or media-libs/libjpeg-turbo. Skipping tests..."
+ return
+ fi
+ perl-module_src_test
+ else
+ ewarn "The test fails if neither of png, jpeg, gif is in USE!"
+ ewarn "Skipping tests..."
+ fi
+}
+mydoc="GD.html"