summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-03-19 01:04:35 +1300
committerKent Fredric <kentnl@gentoo.org>2017-03-19 01:05:17 +1300
commitff8c12006085634961d1f53620506716055ce12e (patch)
tree20cb30072e5f2da4a97ddf53897bdbd8711de002 /dev-perl/Mail-IMAPClient
parentdev-perl/libwww-perl: Bump to version 6.240.0 (diff)
downloadgentoo-ff8c12006085634961d1f53620506716055ce12e.tar.gz
gentoo-ff8c12006085634961d1f53620506716055ce12e.tar.bz2
gentoo-ff8c12006085634961d1f53620506716055ce12e.zip
dev-perl/Mail-IMAPClient: Bump to version 3.390.0
- Remove bad POD tests - Add USE=examples Upstream: - Fix uninitialized value in fetch_hash - Improve error reporting when TLS connections fail - new doretry option to _imap_command - Don't retry the "DONE" command Package-Manager: Portage-2.3.4, Repoman-2.3.2
Diffstat (limited to 'dev-perl/Mail-IMAPClient')
-rw-r--r--dev-perl/Mail-IMAPClient/Mail-IMAPClient-3.390.0.ebuild48
-rw-r--r--dev-perl/Mail-IMAPClient/Manifest1
-rw-r--r--dev-perl/Mail-IMAPClient/files/3.39-makefilepl.patch89
3 files changed, 138 insertions, 0 deletions
diff --git a/dev-perl/Mail-IMAPClient/Mail-IMAPClient-3.390.0.ebuild b/dev-perl/Mail-IMAPClient/Mail-IMAPClient-3.390.0.ebuild
new file mode 100644
index 000000000000..95638104d953
--- /dev/null
+++ b/dev-perl/Mail-IMAPClient/Mail-IMAPClient-3.390.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=PLOBBES
+DIST_VERSION=3.39
+DIST_EXAMPLES=("examples/*")
+inherit perl-module
+
+DESCRIPTION="IMAP client module for Perl"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="test ntlm md5 ssl zlib"
+
+PATCHES=(
+ "${FILESDIR}/${DIST_VERSION}-makefilepl.patch"
+)
+PERL_RM_FILES=(
+ "t/quota.t" # Requires imap server config in test.txt
+ "t/basic.t"
+ "t/pod.t" # Bad author test
+)
+# IO::File, IO::Select, IO::Socket, IO::Socket::INET -> perl-IO
+# Digest::HMAC_MD5 -> Digest-HMAC
+RDEPEND="
+ virtual/perl-Carp
+ virtual/perl-File-Temp
+ >=virtual/perl-IO-1.260.0
+ virtual/perl-Scalar-List-Utils
+ virtual/perl-MIME-Base64
+ >=dev-perl/Parse-RecDescent-1.967.9
+ ntlm? ( dev-perl/Authen-NTLM )
+ md5? (
+ dev-perl/Authen-SASL
+ dev-perl/Digest-HMAC
+ virtual/perl-Digest-MD5
+ )
+ ssl? ( dev-perl/IO-Socket-SSL )
+ zlib? ( virtual/perl-IO-Compress )
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-Test-Simple
+ )
+"
diff --git a/dev-perl/Mail-IMAPClient/Manifest b/dev-perl/Mail-IMAPClient/Manifest
index b8b920cb2e50..071fb3e9e941 100644
--- a/dev-perl/Mail-IMAPClient/Manifest
+++ b/dev-perl/Mail-IMAPClient/Manifest
@@ -1,2 +1,3 @@
DIST Mail-IMAPClient-3.37.tar.gz 188964 SHA256 481df10e0426938dcf6ae641e8e15098ddaeb44ca247772a27b87278f78ba9f3 SHA512 e6baeb880610d55991342fc50acd5bb666a4d94856f4d158172eb5e430aa62296847cb4cec4706398dfbaf7af657ca0024ef92bbb455addd0cd648c47d847fef WHIRLPOOL 7801f9032ad445a0c8994523f5c7bc6455a69b52b16690a00d352575436cc487324f7e1671a808ae84f36af363b521fd752818151dd67c5852da42653398e9db
DIST Mail-IMAPClient-3.38.tar.gz 190487 SHA256 d0f346d111dba93548ceac1192a993210ffcd5f81f83638ee277607bfacc1a4d SHA512 aa2d4ae43ac221db5b99d20884d34ce41fabdc593cee48e7daf7d7048dd351026231f9a4193044f42eb17c8d303b5af0b924bea17fed27c4d0934ca2935b73f3 WHIRLPOOL 29116d21168eb03db194ba80ede6a50074798cebdd07e8a1f35ecb0e45911af0fd71378662039da325c0a56aa915a7a209254efb3816e50453fc637c151e93e3
+DIST Mail-IMAPClient-3.39.tar.gz 190965 SHA256 b541fdb47d5bca93048bcee69f42ad2cc96af635557ba6a9db1d8f049a434ea3 SHA512 156e5f6682d55f2c112ae5065448f0c502d3e748c4405768152ccccd7d944cf949f7c3fd42f30f40c86337457dea5c037959bf29739e4c413e4b45af2b74c222 WHIRLPOOL 434088beb4482afa5b05ed2f64cc65abc5ae8b1f19e29657a10b04ed82c6294294a34665f6ae5426682f3c946514a2ae507082ce128f0f204a5d8509151aeb08
diff --git a/dev-perl/Mail-IMAPClient/files/3.39-makefilepl.patch b/dev-perl/Mail-IMAPClient/files/3.39-makefilepl.patch
new file mode 100644
index 000000000000..1224701a2988
--- /dev/null
+++ b/dev-perl/Mail-IMAPClient/files/3.39-makefilepl.patch
@@ -0,0 +1,89 @@
+diff -Naur Mail-IMAPClient-3.38/Makefile.PL Mail-IMAPClient-3.38/Makefile.PL
+--- Mail-IMAPClient-3.38/Makefile.PL
++++ Mail-IMAPClient-3.38/Makefile.PL
+@@ -4,39 +4,6 @@
+
+ use 5.008_001;
+
+-my @missing;
+-my %optional = (
+- "Authen::NTLM" => { for => "Authmechanism 'NTLM'" },
+- "Authen::SASL" => { for => "Authmechanism 'DIGEST-MD5'" },
+- "Compress::Zlib" => { for => "COMPRESS DEFLATE support" },
+- "Digest::HMAC_MD5" => { for => "Authmechanism 'CRAM-MD5'" },
+- "Digest::MD5" => { for => "Authmechanism 'DIGEST-MD5'" },
+- "IO::Socket::SSL" => { for => "SSL enabled connections (Ssl => 1)" },
+- "Test::Pod" => { for => "Pod tests", ver => "1.00" },
+-);
+-
+-foreach my $mod ( sort keys %optional ) {
+- my $for = $optional{$mod}->{"for"} || "";
+- my $ver = $optional{$mod}->{"ver"} || "";
+- eval "use $mod $ver ();";
+- push @missing, $mod . ( $for ? " for $for" : "" ) if $@;
+-}
+-
+-# similar message to one used in DBI:
+-if (@missing) {
+- print( "The following optional modules were not found:",
+- map( "\n\t" . $_, @missing ), "\n" );
+-
+- print <<'MSG';
+-Optional modules are available from any CPAN mirror, reference:
+- http://search.cpan.org/
+- http://www.perl.com/CPAN/modules/by-module
+- http://www.perl.org/CPAN/modules/by-module
+-
+-MSG
+- sleep 3;
+-}
+-
+ # HACK: die on broken Parse::RecDescent 1.966002 through 1.967009
+ # - rt.cpan.org#74593: Recent changes break Module::ExtractUse and ...
+ # - rt.cpan.org#74733: Fails with Parse::RecDescent >= 1.966_002
+@@ -94,45 +61,4 @@
+ clean => { FILES => 'test.txt' },
+ );
+
+-set_test_data();
+-
+ exit 0;
+-
+-###
+-### HELPERS
+-###
+-
+-sub set_test_data {
+- unless ( -f "lib/Mail/IMAPClient.pm" ) {
+- warn("ERROR: not in installation directory\n");
+- return;
+- }
+-
+- if ( -s "./test.txt" ) {
+- print("The file test.txt will be used for extended tests.\n");
+- return;
+- }
+-
+- print <<EOF;
+-
+-(OPTIONAL) For extended tests during 'make test', create a file
+-'test.txt' in the top level directory of this distribution (the same
+-directory as the Makefile.PL, etc.). This file must contain an IMAP
+-server name or IP (server=...), a user account (user=...), and a
+-password (passed=...). A port (port=....) and an authentication
+-mechanism to be used (authmechanism=...) can also be specified.
+-
+-Example:
+-
+---- BEGIN: test.txt ---
+-server=localhost
+-user=mytestuser
+-passed=mypassword
+-port=143
+---- END: test.txt ---
+-
+-NOTE: When testing is completed, be sure to remove test.txt (either by
+-hand or by 'make clean').
+-
+-EOF
+-}