summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-02-22 19:26:55 +0100
committerThomas Deutschmann <whissi@gentoo.org>2019-02-22 19:28:51 +0100
commit00a66acfad079f77ac0a4c33f852d2a19a3a7f1e (patch)
treeac0fb48e06a5622767b5af7ae3d68bddf42c6883 /dev-php/tcpdf
parentapp-text/poppler: arm64 stable (bug #674666) (diff)
downloadgentoo-00a66acfad079f77ac0a4c33f852d2a19a3a7f1e.tar.gz
gentoo-00a66acfad079f77ac0a4c33f852d2a19a3a7f1e.tar.bz2
gentoo-00a66acfad079f77ac0a4c33f852d2a19a3a7f1e.zip
dev-php/tcpdf: bump to v6.2.26
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-php/tcpdf')
-rw-r--r--dev-php/tcpdf/Manifest1
-rw-r--r--dev-php/tcpdf/tcpdf-6.2.26.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-php/tcpdf/Manifest b/dev-php/tcpdf/Manifest
index 14b72c9737ba..a40e40fbcab7 100644
--- a/dev-php/tcpdf/Manifest
+++ b/dev-php/tcpdf/Manifest
@@ -1 +1,2 @@
DIST tcpdf-6.2.25.tar.gz 17006366 BLAKE2B f95d9d4931d56459d5ae9ea9bcaad72a31abaa8e9404fea17bc69089fb93b89d94a027512568282b6b8758651c3d347c3190a38db7ee200939cc045b9f12650b SHA512 d2e2bdf080c0a6af918a14c4f5704ee4bf7adad76044c89c3165afe392e39fa7bf98271da976cec7f024e3047e1df49090cb0206084efa77bb5b76708d6524c8
+DIST tcpdf-6.2.26.tar.gz 17004923 BLAKE2B bd99f036a808c0063d0cb48e59dab09f313d1dd19095d8131b38c161876f325736da73745a9e47d1ecc4b29b4e961db13761037cfa453d16127761c3518a9c96 SHA512 8ea2b1f2b3cfaa07a903cf286a63ab6b7e5e49881395f905e35740bcecf2ea8ffb1fd569d5dd4f6908918c8be1467be3051dff912416bc8ec80b8848068066be
diff --git a/dev-php/tcpdf/tcpdf-6.2.26.ebuild b/dev-php/tcpdf/tcpdf-6.2.26.ebuild
new file mode 100644
index 000000000000..533692a50169
--- /dev/null
+++ b/dev-php/tcpdf/tcpdf-6.2.26.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="TCPDF is a FLOSS PHP class for generating PDF documents"
+HOMEPAGE="http://www.tcpdf.org/"
+SRC_URI="https://github.com/tecnickcom/TCPDF/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+# Main source is LGPL-3+, some included fonts have other licenses
+LICENSE="LGPL-3+ GPL-3 BitstreamVera GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+RDEPEND="dev-lang/php"
+
+S="${WORKDIR}/${P^^}"
+
+src_install() {
+ insinto /etc
+ doins config/tcpdf_config.php
+ # Create a symlink for the config file, because the library will only
+ # look for it in its own source tree (not in /etc where we've put it).
+ dosym ../../../../../etc/tcpdf_config.php "/usr/share/php/${PN}/config/tcpdf_config.php"
+
+ exeinto "/usr/share/php/${PN}/tools"
+ doexe tools/tcpdf_addfont.php
+
+ insinto "/usr/share/php/${PN}"
+ doins tcpdf*.php
+ doins -r include fonts
+ DOCS=( CHANGELOG.TXT README.md )
+
+ use examples && HTML_DOCS=( examples )
+ einstalldocs
+}