summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2025-01-24 07:02:35 +0100
committerMichał Górny <mgorny@gentoo.org>2025-01-24 08:16:25 +0100
commit7c63eec3491789bb6040c85e32361d7b12ab4b93 (patch)
tree3550cbdc528e28a4c65115d8d27642b07a0e7cde /dev-python/botocore
parentvirtual/dist-kernel: Bump to 5.15.177 (diff)
downloadgentoo-7c63eec3491789bb6040c85e32361d7b12ab4b93.tar.gz
gentoo-7c63eec3491789bb6040c85e32361d7b12ab4b93.tar.bz2
gentoo-7c63eec3491789bb6040c85e32361d7b12ab4b93.zip
dev-python/botocore: Bump to 1.36.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/botocore')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.36.5.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index c9e444380ffa..85a0f56ef92a 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -8,3 +8,4 @@ DIST botocore-1.36.1.gh.tar.gz 14190157 BLAKE2B ff3c5ef62d6eb7c3907187ccb29bedc4
DIST botocore-1.36.2.gh.tar.gz 14197789 BLAKE2B 21441cd52052d117ce05e425c13f34941dcc1ca26a03e2e7eefb6c82584d7faffb548435ebb6b716b72db8149cfe6a3378b79f9174c676fd193c194501b0c844 SHA512 45d9515c493b238a003e5ad264b152b68a62e7ca140ea13111865a4b7c674a7b309a0f550f9782c37966b95c114136b8788f00ba0c83ed4bc61521b593376594
DIST botocore-1.36.3.gh.tar.gz 14202092 BLAKE2B 8760e2afcd12b0982dacb9815bf8030c5dd1b43c27b53bfd0dea558e9f92cc655dc94c39df47a2d130c43103b7a6249585f764169d9d6c615d4392969a2e071e SHA512 fa80cdb2231497d96878719df8307812ac0ec4882c10da27f2ff19f30eed0ca51751e0394b2416bbebb20b8eaf5b3bbc089bffeacc36ac427e351081b7226823
DIST botocore-1.36.4.gh.tar.gz 14204777 BLAKE2B 8a21c35240f272bbf4eacdd5da2ef6b6d65c761ad0c5363311750c7f3d30dd3d0762b0b769055c78ef4778e372ad352d486e098d225fa58eb4dfec1c0531f0df SHA512 55705e9cd0828fad15111e47e7514c2838684bc0a4afdfc529c00a8d30acecf9a535b809e23943f657321a7bfbc5c27f804c5cddae4fe015e636d9f343ae90e7
+DIST botocore-1.36.5.gh.tar.gz 14171897 BLAKE2B 2dad209a50740e417b780ed6bd499e5c36e31563544b4c80b95688f36d444ca61a4bd405d793d64fb85bfa94fb783819e29e15f37d74bb5ce1a43ef385586d5d SHA512 44de481a8b520b9d19a5037b17354dbc2900bec30b476739da8a52d482a9dde0e18438776c6fcf1e783c16b6884b863a0d822e9ef2fdf64eea97875cea97baa0
diff --git a/dev-python/botocore/botocore-1.36.5.ebuild b/dev-python/botocore/botocore-1.36.5.ebuild
new file mode 100644
index 000000000000..9e1580d45581
--- /dev/null
+++ b/dev-python/botocore/botocore-1.36.5.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="
+ https://github.com/boto/botocore/
+ https://pypi.org/project/botocore/
+"
+SRC_URI="
+ https://github.com/boto/botocore/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ <dev-python/jmespath-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+# unbundled packages
+RDEPEND+="
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit}
+}