summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-08-23 21:08:20 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-08-24 21:18:01 +0300
commit27d8ceb8cfe8c704601449d84e4f970039eab20d (patch)
treebdb2550b52a97bae0fb0968b5740daf0ee59ad30 /dev-python/flask-script
parentdev-python/flask-script: add github upstream metadata (diff)
downloadgentoo-27d8ceb8cfe8c704601449d84e4f970039eab20d.tar.gz
gentoo-27d8ceb8cfe8c704601449d84e4f970039eab20d.tar.bz2
gentoo-27d8ceb8cfe8c704601449d84e4f970039eab20d.zip
dev-python/flask-script: enable py3.10, cleanup ebuild
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/flask-script')
-rw-r--r--dev-python/flask-script/files/flask-script-2.0.6-flask_script-everywhere.patch39
-rw-r--r--dev-python/flask-script/flask-script-2.0.6.ebuild23
2 files changed, 18 insertions, 44 deletions
diff --git a/dev-python/flask-script/files/flask-script-2.0.6-flask_script-everywhere.patch b/dev-python/flask-script/files/flask-script-2.0.6-flask_script-everywhere.patch
index b10b2f0a2283..04259c89a420 100644
--- a/dev-python/flask-script/files/flask-script-2.0.6-flask_script-everywhere.patch
+++ b/dev-python/flask-script/files/flask-script-2.0.6-flask_script-everywhere.patch
@@ -1,16 +1,7 @@
-From fcf894b6e4d0ad17489480b722c870aaea600db1 Mon Sep 17 00:00:00 2001
From: anthraxx <levente@leventepolyak.net>
Date: Wed, 6 Sep 2017 12:03:22 +0200
Subject: [PATCH] using flask_script everywhere instead of flask.ext.script
----
- docs/index.rst | 2 +-
- examples/manage.py | 4 ++--
- tests.py | 4 ++--
- 3 files changed, 5 insertions(+), 5 deletions(-)
-
-diff --git a/docs/index.rst b/docs/index.rst
-index 775ffca..9266d4b 100644
--- a/docs/index.rst
+++ b/docs/index.rst
@@ -577,7 +577,7 @@ Then the user can register the sub-manager to their primary Manager (within mana
@@ -22,23 +13,6 @@ index 775ffca..9266d4b 100644
manager.add_command("database", database_manager)
The commands will then be available::
-#diff --git a/examples/manage.py b/examples/manage.py
-#index 5c0dc21..8129555 100755
-#--- a/examples/manage.py
-#+++ b/examples/manage.py
-#@@ -4,8 +4,8 @@
-# import pprint
-#
-# from flask import Flask, current_app
-#-from flask.ext.script import Manager, prompt_choices, Server
-#-from flask.ext.script.commands import ShowUrls, Clean
-#+from flask_script import Manager, prompt_choices, Server
-#+from flask_script.commands import ShowUrls, Clean
-#
-#
-# def create_app(config=None):
-diff --git a/tests.py b/tests.py
-index 93d0071..24f3f15 100644
--- a/tests.py
+++ b/tests.py
@@ -5,8 +5,8 @@
@@ -52,3 +26,16 @@ index 93d0071..24f3f15 100644
from pytest import raises
+--- a/flask_script/__init__.py
++++ b/flask_script/__init__.py
+@@ -12,9 +12,8 @@ from collections import OrderedDict
+ import argparse
+
+ from flask import Flask
+-from flask._compat import text_type
+
+-from ._compat import iteritems
++from ._compat import iteritems, text_type
+ from .commands import Group, Option, Command, Server, Shell
+ from .cli import prompt, prompt_pass, prompt_bool, prompt_choices
+
diff --git a/dev-python/flask-script/flask-script-2.0.6.ebuild b/dev-python/flask-script/flask-script-2.0.6.ebuild
index cd84dc29df06..1932eee2f304 100644
--- a/dev-python/flask-script/flask-script-2.0.6.ebuild
+++ b/dev-python/flask-script/flask-script-2.0.6.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
MY_PN="Flask-Script"
@@ -14,32 +14,19 @@ HOMEPAGE="https://flask-script.readthedocs.io/en/latest/
https://flask-script.readthedocs.io/en/latest/
https://pypi.org/project/Flask-Script/"
SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
RDEPEND=">=dev-python/flask-0.10.1-r1[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
-
-S="${WORKDIR}/${MY_P}"
PATCHES=( "${FILESDIR}/${P}-flask_script-everywhere.patch" )
-python_compile_all() {
- use doc && emake -C docs html
-}
+distutils_enable_tests pytest
+distutils_enable_sphinx docs
python_test() {
- py.test tests.py || die "Tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
- distutils-r1_python_install_all
+ epytest tests.py
}