summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-12-24 08:27:45 +0100
committerMichał Górny <mgorny@gentoo.org>2024-12-24 12:17:14 +0100
commit05b8c2df782e4ae1299d79b68ae2dbb8fe473daa (patch)
tree8c147dc2ff1ac95822523dbc951a3694f52b0d15 /dev-python/flatbuffers
parentdev-libs/flatbuffers: Bump to 24.12.23 (diff)
downloadgentoo-05b8c2df782e4ae1299d79b68ae2dbb8fe473daa.tar.gz
gentoo-05b8c2df782e4ae1299d79b68ae2dbb8fe473daa.tar.bz2
gentoo-05b8c2df782e4ae1299d79b68ae2dbb8fe473daa.zip
dev-python/flatbuffers: Bump to 24.12.23
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/flatbuffers')
-rw-r--r--dev-python/flatbuffers/Manifest1
-rw-r--r--dev-python/flatbuffers/flatbuffers-24.12.23.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/flatbuffers/Manifest b/dev-python/flatbuffers/Manifest
index 080fa756df8b..84992c3602ab 100644
--- a/dev-python/flatbuffers/Manifest
+++ b/dev-python/flatbuffers/Manifest
@@ -1 +1,2 @@
+DIST flatbuffers-24.12.23.gh.tar.gz 2326944 BLAKE2B d32d8f861cfb2eff23cdedda01d4e0bd2f203c4d4bf1d0ade1a06ce9caf9fcf3b43c58f2e5bf9014892c184f819ab8005b322d6e96b9f3c9b9c5624eef12642f SHA512 f97762ba41b9cfef648e93932fd789324c6bb6ebc5b7aeca8185c9ef602294b67d73aea7ae371035579a1419cbfbeba7c3e88b31b5a5848db98f5e8a03b982b1
DIST flatbuffers-24.3.25.gh.tar.gz 2297829 BLAKE2B f3a5a94119a1b1b63fba9126e1cdff7ab712996bfc0d65626a679405f62dfa722bc5de244ef775fba336224b60feff3aa27acf54bed027c4013590b4afbefe7c SHA512 e2a614f4fc526ce07bfe1e1bc79efd3c87acbdb93aee7b42994d4855abd2593f36b5ca1edb53c7dcd470d5fbe14a3e394bd75dcebb4458cc0aeb33d622a3c662
diff --git a/dev-python/flatbuffers/flatbuffers-24.12.23.ebuild b/dev-python/flatbuffers/flatbuffers-24.12.23.ebuild
new file mode 100644
index 000000000000..e82e5d455faa
--- /dev/null
+++ b/dev-python/flatbuffers/flatbuffers-24.12.23.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="RFC 7049 - Concise Binary Object Representation"
+HOMEPAGE="
+ https://github.com/google/flatbuffers/
+ https://pypi.org/project/flatbuffers/
+"
+SRC_URI="
+ https://github.com/google/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S=${WORKDIR}/${P}/python
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ test? (
+ dev-python/numpy[${PYTHON_USEDEP}]
+ )
+"
+
+src_prepare() {
+ cd "${WORKDIR}/${P}" || die
+ eapply "${FILESDIR}/${PN}-24.3.25-numpy-2.patch"
+ cd "${S}" || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ cd "${WORKDIR}/${P}/tests" || die
+ # zeroes means without benchmarks
+ "${EPYTHON}" py_test.py 0 0 0 0 false || die
+ "${EPYTHON}" py_flexbuffers_test.py -v || die
+}