summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-18 16:05:56 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-18 16:47:33 +0100
commit0225c3530c7a7096c510394275fec780f285eea3 (patch)
tree26af9a39751cc53b9b24836503a12ed9b21dfed1 /dev-python/hcloud
parentdev-python/subunit: Bump to 1.4.4 (diff)
downloadgentoo-0225c3530c7a7096c510394275fec780f285eea3.tar.gz
gentoo-0225c3530c7a7096c510394275fec780f285eea3.tar.bz2
gentoo-0225c3530c7a7096c510394275fec780f285eea3.zip
dev-python/hcloud: Bump to 1.32.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/hcloud')
-rw-r--r--dev-python/hcloud/Manifest1
-rw-r--r--dev-python/hcloud/hcloud-1.32.0.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/hcloud/Manifest b/dev-python/hcloud/Manifest
index 07a4850bcf0e..7cb000461067 100644
--- a/dev-python/hcloud/Manifest
+++ b/dev-python/hcloud/Manifest
@@ -1,2 +1,3 @@
DIST hcloud-python-1.30.0.gh.tar.gz 108965 BLAKE2B b078310dcab67b37744ab285fe3c3207956f778de9c85fb64cbf4777250b3852a7bb19a6e2498a19bc1027a7b5edebc3aa0011192edf057ce1a1591e610387ef SHA512 459fdeff833a86c9c6869e06eac5b96250d2f0c9d1ebf55053c278ae8417af04611d4bb7bd89a757f75e5bc7303e13e235ba57496efcc59f63c38cf48fb87d82
DIST hcloud-python-1.31.0.gh.tar.gz 109239 BLAKE2B 26a58fe75386f98403afd6f13c55768fa676d130243c9c8ef70c0c6310e2ec76235eadc50122b2ce203f190244e0d36f4d7b05e07c2e8fbe5707120634e1ef6c SHA512 be3d3e643e970390faae6d3da9e75b754d167398a7a6d04f06a4dea1bc79c160a39184365019ed1f8c7242a85f5deb9d43d8923cc1907861d38089fe8835ed62
+DIST hcloud-python-1.32.0.gh.tar.gz 109858 BLAKE2B 7e242a92c81278facd7f9d2042d2d36787153215a72e97da7616f7d6b6ca6c06fadfd6b33bdab3699a8d8ac6ec1d7327b78a224a3f674a13a7d06791e91d4658 SHA512 013cd3a7e54b12348e4ec87e489b461c41822a85cd9fafc4421a8bb404ecf1fa079d99217db5f770e893ab9bb7223b588e4429968b8339b4d23654610dfa80c3
diff --git a/dev-python/hcloud/hcloud-1.32.0.ebuild b/dev-python/hcloud/hcloud-1.32.0.ebuild
new file mode 100644
index 000000000000..498400383d05
--- /dev/null
+++ b/dev-python/hcloud/hcloud-1.32.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+MY_P=hcloud-python-${PV}
+DESCRIPTION="Official Hetzner Cloud python library"
+HOMEPAGE="
+ https://github.com/hetznercloud/hcloud-python/
+ https://pypi.org/project/hcloud/
+"
+# sdist is missing doc assets as of 1.19.0
+# https://github.com/hetznercloud/hcloud-python/pull/183
+SRC_URI="
+ https://github.com/hetznercloud/hcloud-python/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="examples"
+
+RDEPEND="
+ >=dev-python/python-dateutil-2.7.5[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.20[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs \
+ dev-python/myst-parser \
+ dev-python/sphinx-rtd-theme
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # Integration tests need docker:
+ # https://github.com/hetznercloud/hcloud-python/blob/master/.travis.yml#L16
+ tests/integration
+)
+
+python_install_all() {
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}