summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-12 15:30:30 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-12 15:36:25 +0200
commit9dc509dbbafc3a32603e7727a7a486479ba1038c (patch)
treeaff1e6518b1c98190ea88b73e7c67441ba709859 /dev-python/hyperlink
parentdev-python/automat: Enable py3.11 (diff)
downloadgentoo-9dc509dbbafc3a32603e7727a7a486479ba1038c.tar.gz
gentoo-9dc509dbbafc3a32603e7727a7a486479ba1038c.tar.bz2
gentoo-9dc509dbbafc3a32603e7727a7a486479ba1038c.zip
dev-python/hyperlink: Enable py3.11
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/hyperlink')
-rw-r--r--dev-python/hyperlink/hyperlink-21.0.0-r1.ebuild11
1 files changed, 8 insertions, 3 deletions
diff --git a/dev-python/hyperlink/hyperlink-21.0.0-r1.ebuild b/dev-python/hyperlink/hyperlink-21.0.0-r1.ebuild
index 4b4be9668000..bdab0cca4a9c 100644
--- a/dev-python/hyperlink/hyperlink-21.0.0-r1.ebuild
+++ b/dev-python/hyperlink/hyperlink-21.0.0-r1.ebuild
@@ -4,19 +4,24 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{8..10} )
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
inherit distutils-r1
DESCRIPTION="A featureful, correct URL for Python"
-HOMEPAGE="https://github.com/python-hyper/hyperlink https://pypi.org/project/hyperlink/"
+HOMEPAGE="
+ https://github.com/python-hyper/hyperlink/
+ https://pypi.org/project/hyperlink/
+"
SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
LICENSE="BSD MIT"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~x64-macos"
-RDEPEND="dev-python/idna[${PYTHON_USEDEP}]"
+RDEPEND="
+ dev-python/idna[${PYTHON_USEDEP}]
+"
distutils_enable_tests pytest