summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-08-21 18:39:24 +0200
committerMichał Górny <mgorny@gentoo.org>2023-08-21 18:44:35 +0200
commitf7387c317c6c21b398f731376423e2bc0bfb00d4 (patch)
tree3a879ce90f47f9dfc8f8224258b01a406f54d462 /dev-python/identify
parentapp-misc/tmuxp: add 1.29.0 (diff)
downloadgentoo-f7387c317c6c21b398f731376423e2bc0bfb00d4.tar.gz
gentoo-f7387c317c6c21b398f731376423e2bc0bfb00d4.tar.bz2
gentoo-f7387c317c6c21b398f731376423e2bc0bfb00d4.zip
dev-python/identify: Bump to 2.5.27
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/identify')
-rw-r--r--dev-python/identify/Manifest1
-rw-r--r--dev-python/identify/identify-2.5.27.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/identify/Manifest b/dev-python/identify/Manifest
index 486a5b3ee20f..99a806db7913 100644
--- a/dev-python/identify/Manifest
+++ b/dev-python/identify/Manifest
@@ -1 +1,2 @@
DIST identify-2.5.26.gh.tar.gz 101549 BLAKE2B 383c6467436107cf98a667f1db3ab63f42aadff8f51d2f6bedf715dd45590eeb5fe7b3d6572b7704a7ae613d079a22a2d84c86581b7a63b7578807e06034aa70 SHA512 4c17c7f40b14fd45649e0a6b6885e2d96a1ce3cf91fbc1092fdb9b92d7bf2ac35b0c04a24bb3e77f3188a3c8d00f57dbe19ca660e1e08b60cdb60385f340c4bd
+DIST identify-2.5.27.gh.tar.gz 101565 BLAKE2B c4b29509d94912b15c35dfbee9b829594dc1953a7f6122cd4955042849686d53a79c7f9049f312226e5e55a148e4b3bc60158e836e9b9a0d5ca2de0cb133a1af SHA512 a604088628b2aeeaf8cb04a91f197bbc567d3c3e17047400201cccae5b168d92ebac26e181b835fa7c18f78d051795d7c25165596c2636f882098f63bac527d6
diff --git a/dev-python/identify/identify-2.5.27.ebuild b/dev-python/identify/identify-2.5.27.ebuild
new file mode 100644
index 000000000000..906b58d7a709
--- /dev/null
+++ b/dev-python/identify/identify-2.5.27.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="File identification library for Python"
+HOMEPAGE="
+ https://github.com/pre-commit/identify/
+ https://pypi.org/project/identify/
+"
+SRC_URI="
+ https://github.com/pre-commit/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/ukkonen[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest