summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-02 09:24:13 +0100
committerMichał Górny <mgorny@gentoo.org>2021-03-02 09:24:13 +0100
commitdcf0d452d584c407f1252a539d9ad808e8ce5d96 (patch)
treec01c2cbc2028f6254fa609da8c098fc596087255 /dev-python/jaraco-collections
parentdev-python/mako: Remove old (diff)
downloadgentoo-dcf0d452d584c407f1252a539d9ad808e8ce5d96.tar.gz
gentoo-dcf0d452d584c407f1252a539d9ad808e8ce5d96.tar.bz2
gentoo-dcf0d452d584c407f1252a539d9ad808e8ce5d96.zip
dev-python/jaraco-collections: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jaraco-collections')
-rw-r--r--dev-python/jaraco-collections/Manifest1
-rw-r--r--dev-python/jaraco-collections/jaraco-collections-3.0.0-r1.ebuild55
2 files changed, 0 insertions, 56 deletions
diff --git a/dev-python/jaraco-collections/Manifest b/dev-python/jaraco-collections/Manifest
index e63b1313bb06..82e7ae380a6e 100644
--- a/dev-python/jaraco-collections/Manifest
+++ b/dev-python/jaraco-collections/Manifest
@@ -1,3 +1,2 @@
-DIST jaraco.collections-3.0.0.tar.gz 16439 BLAKE2B ff3690d85d91da8d88945e9ab8d16d13c7d0f67a9334f706701f9b392d8cffdd9450b2d6051a92799564cfc81310e45f50368ab729a0b68c08a9c8b0ccd9627d SHA512 c6c5d28fe4b3940c81c68bf877249805db3f508d83a0071947c7a5596d3636631df91cc6e87802b0fa6cd5c8bdd1ef2f39b924471666b44d2147cb64ad1533ad
DIST jaraco.collections-3.1.0.tar.gz 18206 BLAKE2B c420b3c65c048840f2957ebff0e69a7e2d3db515801a54d829bc2dd9f77b804066ef15766c915b764a148eaa945fc9a30576bb00a645f4c124c031b6ccc64184 SHA512 9a3e4e60cd497ee2ed4a092bd823ecffe0d20293dd9ba491fd2c4e5df2481042efa8ba52503b001e11908982608852a0588cd70b4957d0551c066be97389652c
DIST jaraco.collections-3.2.0.tar.gz 18195 BLAKE2B 51510dd5053563319eac1c412deadac0a5f99ce3144d44150b5835ab92a05529998676fdcb577a5e725b19b4953c47c662e2f3eaa791de955c2493014713dd11 SHA512 cfea2de312781ec9d7a51752570432ec85e62834d02582023378ce0815e0c25f4d4e6afad8486559aa4e3f6fa6e602df917fdb11ed7a72423bea7ae816675258
diff --git a/dev-python/jaraco-collections/jaraco-collections-3.0.0-r1.ebuild b/dev-python/jaraco-collections/jaraco-collections-3.0.0-r1.ebuild
deleted file mode 100644
index 73978bf92b19..000000000000
--- a/dev-python/jaraco-collections/jaraco-collections-3.0.0-r1.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} pypy3 )
-inherit distutils-r1
-
-MY_PN="${PN/-/.}"
-DESCRIPTION="Models and classes to supplement the stdlib collections module"
-HOMEPAGE="https://github.com/jaraco/jaraco.collections"
-SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~ia64 ppc ~ppc64 x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-# TODO: remove six when the following PR is merged:
-# https://github.com/jaraco/jaraco.collections/pull/5
-RDEPEND="
- dev-python/jaraco-classes[${PYTHON_USEDEP}]
- dev-python/jaraco-text[${PYTHON_USEDEP}]
- >=dev-python/six-1.7.0[${PYTHON_USEDEP}]
-"
-BDEPEND="
- >=dev-python/setuptools_scm-1.15.0[${PYTHON_USEDEP}]
- test? (
- ${RDEPEND}
- >=dev-python/pytest-2.8[${PYTHON_USEDEP}]
- )
-"
-
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-PATCHES=(
- "${FILESDIR}/jaraco-collections-3.0.0-pypy.patch"
-)
-
-distutils_enable_sphinx docs '>=dev-python/jaraco-packaging-3.2' \
- '>=dev-python/rst-linker-1.9'
-
-python_test() {
- # Override pytest options to skip flake8
- PYTHONPATH=. pytest -vv --override-ini="addopts=--doctest-modules" \
- || die "tests failed with ${EPYTHON}"
-}
-
-# https://wiki.gentoo.org/wiki/Project:Python/Namespace_packages#File_collisions_between_pkgutil-style_packages
-python_install() {
- rm "${BUILD_DIR}"/lib/jaraco/__init__.py || die
- # note: eclass may default to --skip-build in the future
- distutils-r1_python_install --skip-build
-}